"The remote server returned an error: (401) Unauthorized" - It has been working perfectly!!!!!!!!!

johnf471
Participant

"The remote server returned an error: (401) Unauthorized" - It has been working perfectly!!!!!!!!!

Hi

 

I have a windows service I have written to retrieve campaigns and campaigns stats via the API

 

It has been working perfectly for 2 weeks

 

All of a sudden I'm getting "The remote server returned an error: (401) Unauthorized." as an error

 

I have not changed my username OR password and my API key is still shows as ACTIVE

 

Any ideas?

 

Thanks

6 REPLIES 6
Shannon_W
Employee

Hi,

 

We are currently experiencing issues on our server that are causing a 401 (invalid credentials) response to go out, incorrectly. We are currently investigating the cause of the issue, and hope to have it resolved as soon as possible.

 

We don't currently have enough details about the cause of the issue to give an estimated time that we think we will have it resolved, but please check back with us if you are still getting the error later today!

 

Best Regards,
Shannon W.
API Support Specialist

johnf765
Occasional Participant

THANK YOU!!!!!!!!!!

 

You have made my friday!

 

I thought I was going mad!

 

Cheers Shannon

StephanieC47
Occasional Participant

Having issues again?? My clients are complaining about 401 errors again and we made no changes to our software. Please HELP!!!

Hi,

 

You've been the first to report this in a quite a while (certainly the first report of this today).  I just tested to make sure I could make a simple call to my account via the API, and I was able to make a successful get contact request with my normal credentials.

 

Is it more than one Constant Contact account that is reporting this?  Sometimes people will change their username or passwords and not realize it could have this effect.   I will certainly keep my eyes open for any strange behavior or other reports of this while I wait for your response.

 

Best Regards,

Shannon W.

API Support Specialist

StephanieC47
Occasional Participant

Yes, I have had two different people report it in the past hour. I don't see any current erorrs in our logs for it, but we had quite a few just a little bit ago.

Thank you for the information.  Could you private message me, or email me, the Constant Contact usernames of the people who reported this to you, to webservices@constantcontact.com so that I can take a look at our logs?

 

Thanks in advance!

Shannon W.

API Support Specialist

Developer Portal

View API documentation, code samples, get your API key.

Visit Page