cancel
Showing results for 
Search instead for 
Did you mean: 

500 error retrieving registrant details - getting error in UI too

Highlighted
Advisor

500 error retrieving registrant details - getting error in UI too

I'm getting a 500 error retrieving the details of a registrant:

 

username for API call: 0017score

event ID: a07e4dhub5q76d3d944  

registrant ID 001GFoblkIUYHAifpuYZHfFAoFV8pAjYvCVPXmShDPXioQRZjT6nL3QqLDdewzuTfVP

 

When I look at the Constant Contact UI, I'm getting an error when I look at the details of this registrant, so there is obviously a problem with the system. Please resolve this.


Thanks,

Phil

 

 

 

Phil Ayres

Principle - Consected
3 REPLIES 3
Moderator

Re: 500 error retrieving registrant details - getting error in UI too

Thanks for the report Phil.  We have had a couple of reports of this through our normal support team and our engineering team is looking into it as I'm typing this. The good news is that this is not a problem with our API or a problem with the data for this registrant, all the data is stored fine and we can see it in the database as well as the exported reports in this customer's account.

 

When we have more information on this, we'll get it posted here.  Hopefully we'll have some news to share soon.

Dave Berard
Senior Product Manager, Constant Contact
Visitor

Re: 500 error retrieving registrant details - getting error in UI too

Hello,

 

I am trying to get the registrant details for a registrant but am receiving a (500) Internal Server Error. I first get a list of events and parse the event id for the event I am interested in. I then get a list of registrants based on the event id. This all works great.

 

Now, however, when I try to get the registrant details using https://api.constantcontact.com/ws/customers/{user-name}/events/{event-id}/registrants/{registrant-i... I get the 500 error. This isn't consistent as for about half of the events I can pull registrant details successfully. It seems for the events that I get the error, every registrant gives me the error. I can view all registrant details successfully in the web application.

 

Any ideas/suggestions? Much appreciated!

Moderator

Re: 500 error retrieving registrant details - getting error in UI too

Hey,

 

I believe we're investigating this with you via email, and we're still looking into the exact cause. Just let us know if you have any extra questions while we work on this. Thanks!

Nick Galbraith
Support Engineer