cancel
Showing results for 
Search instead for 
Did you mean: 

API error (v2)

Highlighted
Regular Visitor

API error (v2)

Hi everyone,

 

After 3 mostly uneventful years with a custom CC integration with our WordPress-based website, I'm all of the sudden seeing the following error:

 

PHP Fatal error: Uncaught Error: Call to undefined method Ctct\\ConstantContact::getLists()

 

Everything was fine in early June (last time anything related to the plugin was used), so I'm kind of at a loss because nothing has been updated with the plugin since, and I've verified the following with our host and my own review that within the past 30 days since the plugin last worked:

 

  • There have been no PHP version updates
  • The WordPress version hasn't changed
  • Our Mashery API key is valid/active
  • API SDK v2 being used is the most recent

Is there anything new with the API I'm missing? Thanks so much!

1 REPLY
Moderator

Re: API error (v2)

Hello,

Thank you for reaching out to the API Support team here at Constant Contact.

That error is coming directly from PHP, so any changes made to our base API wouldn't lead to this error. We have not made any updates to our PHP SDK, but even if we had the new version woudl need to be installed on your site before the changes would have taken effect.

This error message indicates that PHP cannot locate the getLists() method. I would check to make sure that our SDK is installed properly, and that your PHP code is initially calling it correctly. Troubleshooting this further beyond that would require me to take a look at the code. If needed, please email webservices(at)constantcontact.com with a copy of the code you are using and we can take a closer look.

Sincerely,
David B.
Tier II API Support Engineer

Still need help?
You can post a new message in the Community or find us on Twitter Mon-Fri 8am - 8pm ET. We've got real people waiting to help you out. Click below to start a conversation!