API is updating contact list but Welcome email doesnt trigger

JustinW19
Regular Participant

API is updating contact list but Welcome email doesnt trigger

My CRM is communicating and updating our Contact list (not the default one) within Constant Contact's backend via the API. Everytime a new contact is added that means we have a new customer so I want our Welcome email to fire off. I have the welcome email setup but it is not firing. How do I get the Welcome to fire off based on a new contact being added from the API?

11 REPLIES 11
Shannon_W
Employee

Hi,

 

You just need to set the opt in source as "ACTION_BY_CONTACT."  If the welcome email isn't firing, the opt in source must be set to "ACTION_BY_CUSTOMER."

 

Best Regards,

Shannon W.

API Support Specialist

JustinW19
Regular Participant

First off, thank you for the help.

 

We made the adjustments you wrote to the API but the Welcome email is still not firing. Now the contact list that is being updated is not the default General Interest (Your default list)More Info list. It is alist I named "Customers". Not sure if that matters or not.

 

 

Hello,

 

If you are submitting a contact as ACTION_BY_CONTACT that will trigger a welcome email, however, the welcome email can only be triggered the very first time that a contact is added to your account. This means that a contact that was previously added to your account as ACTION_BY_CUSTOMER will not receive a welcome email if they are submitted again as ACTION_BY_CONTACT.

 

Sincerely,

Elijah G.

Tier 2 Support

Elijah G.
API Support Engineer
JustinW19
Regular Participant

Hi Elijah,

 

These are brand new contacts. They have never been in the system before. The welcome email is NOT being sent when it is set to ACTION_BY_CONTACT. The welcome email is NOT being sent when it is set to ACTION_BY_CUSTOMER.

 

From what I understand the proper setting is ACTION_BY_CONTACT if I want new contacts who are added via API to automatically be emailed the welcome message correct?

 

This is the current setting and they are not receiving it. I feel like it involves the general list vs the second contact list I am using. I have no contacts in the default general list but my second list is populating with new contacts properly. They just are not getting the welcome email message.

 

Thanks!!!

Hi,

 

It sounds like you're doing everything correctly.  This might be an account-specific issue, specific to your domain, or an email address specific issue.  Here are the things I can think of that might be going wrong:

 

1.  You have confirmed opt-in on in the account, but the new contact should still be getting a 'confirm you want to be on this list' email.

 

2.  Your network/domain is blocking the welcome emails, although they are getting sent.  Check your mail logs to see if your server received those welcome emails, and if you blocked them, see this FAQ on how to whitelist us.

 

3.  You are adding a role address (e.g. info@, sales@, support@, etc).  Our servers don't send mail to commonly used role addresses.

 

Best Regards,

Shannon W.

API Support Specialist

JustinW19
Regular Participant

I am using a support@.

 

I will try welcome@

Perfect, here is a list of role addresses we won't send to.

 

Best Regards,

Shannon W.

API Support Specialist

JustinW19
Regular Participant

I was using support@ as the send email address.

 

I was trying to send the welcome to a normal email address.

 

Can you elabarate on this:

 

1.  You have confirmed opt-in on in the account, but the new contact should still be getting a 'confirm you want to be on this list' email.

 

***Update - I have confirmed opt in off. It was set to off this entire time.***

JustinW19
Regular Participant

I just spoke with someone in support and they said the reason was becuase the "Added by" column was stating "Site Owner".

 

It needs to say "Added by Contact"

 

How do I make this switch in the API?

 

Thanks

Hi,

 

Elijah and I had essentially the same answer for this in our first replies.  I'm not sure how to clarify.  

 

You need to set the opt in source as "ACTION_BY_CONTACT" through the API.  

 

If you post your code (with any personal details redacted), I can most likely give you a more clear example or guidance.  This is the line you need if you're using our PHP wrapper (but replace $contactObj with whatever you called your contact object):

 

$contactObj->optInSource = "ACTION_BY_CONTACT";

 

 

Best Regards,

Shannon W.

API Support Specialist

SaroK5
Frequent Participant

Your IP is included within the JSON request.

Your IP is also stored in the Constant contact database and linked to your email.

Whatever action you perform with that IP address will be registered as 'action by owner'.

Try going incognito and using another email address and see if it is fixed.

Developer Portal

View API documentation, code samples, get your API key.

Visit Page