All contacts uploaded via "bulkUrlEncoded" are rejected

Occasional Participant

All contacts uploaded via "bulkUrlEncoded" are rejected

We are currently using


bulkUrlEncoded uploads successfully, but file conversion on the server fails and all contacts are rejected.  Our format is:


Email Address, First Name, Last Name, Custom Field 1
"", "John", "Smith", "1234567890"
"", "Jane", "Doe", "097654321"


It appears that your server no longer handles the quotation marks.




After investigating this issue, it appears that what you are experiencing is the system is not stripping the quotes from the email addresses when they are processed. This causes the email to be seen as "" instead of Without the quotes stripped, it is technically an invalid address. I have reached out to the other members of our development team so that we can look into this further in our end.


For the immediate term, this issue could be resolved by automatically stripping quotes from the email address field on your imports. This should not present an issue, as CSV formatted data normally uses quotes when there are spaces or commas included in the field, and an email address is not valid with commas or with spaces.


If you do have any questions or concerns, please reply to this thread and we will be happy to assist you!

Elijah G.
API Support Engineer

Is there an equivalent in api v2 for   v1 BulkUrlEncoded ?


We have several clients now receiving this error as well. The email, first name, and last name all appear to not have the quotation marks stripped. This needs to be escalated in priority immediately. They are at a standstill until this gets resolved.

I've just tried using the API v2 method of AddContactsMultipartActivity from the C# library that looks somewhat equivalent.  It's not.  There are problems with custom fields.  That API call fails if I pass in my friendly names for custom fields.  If I instead pass in "CUSTOM FIELD 1", "CUSTOM FIELD 2" etc, it will create the contacts, but NOT populate the custom fields at all.


If you don't have something working in API v2, you cannot break it or remove it from API v1.


I should add too, I tried the bulkurlencoded piece with stripping the quotes on my side first.  That doesn't work either.

Plus, while stripping the quotes from around just the email might work, you can't do that for all fields sent, since other fields allow commas and spaces. And all fields have the quotes still in them in your system, so users can't put things like name and custom fields into emails, otherwise the email will look like 'Dear "John" "Doe",...', which is unacceptable.


Have you guys determined how you will fix all the contacts that have this error in your system now?

Developer Portal

View API documentation, code samples, get your API key.

Visit Page