The Community is hosting an End of Summer sweepstakes! Participants must complete tasks to earn tickets that will enter them with a chance to win a free year of Constant Contact and other great prizes!*
*No Purchase Necessary. For Official Rules, visit here. Constant Contact’s End of Summer 2020 Sweepstakes ends on October, 20, 2020 at 11:50 PM EST.

CCSFG 0.0.6 "Cannot open ../ccsfg.log"

Highlighted
Occasional Participant

CCSFG 0.0.6 "Cannot open ../ccsfg.log"

Hi Folks,

 

When run the CCSFG setup.php file, I get this message:

 

Cannot open ../ccsfg.log

 

Just for testing purposes, I tried commenting out the line in the index.php file that calls/updates the .log file, and I get a similar message:

 

Cannot open ../config.php

 

I see from earlier posts, and in the functions.php file itself, that CCSFG is supposed to generate its own config.php file on first run, but that doesn't seem to be happening -- ditto the .log file.

 

Per earlier posts, I've set permissions on CCSFG files to 644, and folders to 755.

 

What am I doing wrong?

 

Thanks!

-Richard M., Seattle 

9 REPLIES 9
Highlighted
Employee

Re: CCSFG 0.0.6 "Cannot open ../ccsfg.log"

Hi Richard,

 

Can you make sure you are using PHP 5 or better?  Older versions of PHP won't work.

 

Let me know if that helps!

 

Shannon W.

Constant Contact Support

Highlighted
Occasional Participant

Re: CCSFG 0.0.6 "Cannot open ../ccsfg.log"

Yes, I'm running PHP 5.1.6.

Apparently that's not the issue.

 

***** NEW INFO *****

 

Interestingly, when I deleted the CCFSG directory from my server, uploaded a fresh copy and set proper permissions, then  there appeared (seemingly automatically) a config.php and a ccsfg.log file in the main CCSFG folder - that wasn't true before.

 

HOWEVER, unfortunately, the setup/index.php file still cannot load the .log file.. I still get "Cannot open ../ccsfg.log", even though I can see that the file is there.

 

Any help appreciated!

 

Thx,

-Richard M

 

Highlighted
Employee

Re: CCSFG 0.0.6 "Cannot open ../ccsfg.log"

Hey,

 

This sounds like it could be a permissions issue.  What are the permission values for files and folders?  Also which version of cURL do you have on your server? 

Ryan Davis
Quality Engineer
Highlighted
Occasional Participant

Re: CCSFG 0.0.6 "Cannot open ../ccsfg.log"

Per my original post, I've configured permissions as suggested in other threads here:

 

folders: 755

files: 644

 

cURL is enabled, version is  libcurl/7.15.5 OpenSSL/0.9.8b zlib/1.2.3 libidn/0.6.5

 

Thx,

-RM

Highlighted
Employee

Re: CCSFG 0.0.6 "Cannot open ../ccsfg.log"

Hey,

 

The issue sounds server related but lets try to create a config.php file and see what happens from there. The file contains this:

 

<?php
class CC_Config { 
var $login = 'your-username';
var $password = 'your-password';
var $apikey = "your-api-key"; 
var $contact_lists = array("General Interest");
var $force_lists = false; 
var $included_fields = array("EmailAddress");
var $custom_field_labels = array("Custom Field 1","Custom Field 2","Custom Field 3","Custom Field 4","Custom Field 5","Custom Field 6","Custom Field 7","Custom Field 8","Custom Field 9","Custom Field 10","Custom Field 11","Custom Field 12","Custom Field 13","Custom Field 14","Custom Field 15");
var $show_contact_lists = true;
var $actionBy = "ACTION_BY_CONTACT"; 
var $success_url = "";
var $failure_url = "";
var $make_dialog = "";
} 
?>

 

Ryan Davis
Quality Engineer
Highlighted
Occasional Participant

Re: CCSFG 0.0.6 "Cannot open ../ccsfg.log"

Hi Ryan.. 

 

The "setup/index.php" script is failing right near the top, where it calls the "../ccsfg.log" file... the script "cannot open" it.. this occurs before it even tries to call the "config" file.

 

I did upload the config file you gave me, and tried commenting the preceding log-related line out of the script, temporarily, to see if I could get the config file to load.. The script *did* recognize the "config" file (which it wasn't doing before -- see my earlier post).

 

So, that's progress, of a sort.. HOWEVER, when the utility proceeded to the "login.php" file, it failed again: "cannot open" the log file, like before. If I comment out that line near the top of the "login.php" file, I get the login screen, but attempting to log in gives me *another* "cannot open ../ccsfg.log" error.

 

It appears that, at every point in a given script where the "log" file is called, I get the same "cannot open" error.. even though there is a .log file in that location.

 

This leads me to think that the "log" file on my server is not correctly configured. When I open it, it's essentially empty, with one commented line in it:   " // config file "  That can't be right....?

 

**** Can you send me the code for what the log file should look like in its initial state, the same way you did with the "config" file? ****

 

Thanks!

 

-RM

Highlighted
Employee

Re: CCSFG 0.0.6 "Cannot open ../ccsfg.log"

Hey Kate,

 

Have you tried reuploading the files again but make sure they transfer as binary?

 

You can make a log file which is ccsfg.log

 

2011-11-15T18:02:03-05:00 - ### Setup Home Page ###. 

 would be the contents.

 

 

Ryan Davis
Quality Engineer
Highlighted
New Member

Re: CCSFG 0.0.6 "Cannot open ../ccsfg.log"

Same issue here. Folder and file permissions are set right (755 and 644 resp.), php version is 5.3.3.

I had unzipped the folder on my harddrive, then uploaded the whole thing to my website and now I'm trying to run the setup, as laid out in the documentation. Same error as above: "Cannot open ../ccsfg.log"

 

I created the log file and put the text in (like what you suggested in the previous msg).. to no avail.

 

Please help!

Highlighted
Honored Contributor

Re: CCSFG 0.0.6 "Cannot open ../ccsfg.log"

Hello,

 

In addition to what you see above, there are a couple things you can check:

 

- While 644 is normally the ideal setting, that does restrict writing the file to only the owner. If the owner is you, but the webserver is operating under a different user, then the server will be blocked from anything execpt reading the file. I would double-check your file permissions to make sure that the server application has write access to the file. This may require changing ownership of the file.

- I found this information on the PHP documentation for fopen, which is used here: "Note: When safe mode is enabled, PHP checks whether the directory in which the script is operating has the same UID (owner) as the script that is being executed."

 

Sincerely,

Elijah G.

API Support Specialist

Elijah G.
API Support Engineer
Developer Portal

View API documentation, code samples, get your API key.

Visit Page

Constant Contact 2020 End of Summer Community Sweepstakes!

The Constant Contact User Community is hosting a sweepstakes. The more you participate, the more chances you have to win! Read on to learn more...

Read More
Featured