Error 400: Please enter an address

SOLVED
Go to solution
ShawnM641
Frequent Participant

Error 400: Please enter an address

I thought I had this whole thing nailed and now I'm getting this new error.

 

<?xml version="1.0" encoding="UTF-8"?>
<entry xmlns="http://www.w3.org/2005/Atom">
<link href="/ws/customers/smckeenews4/campaigns" rel="edit"/>
<id>http://api.constantcontact.com/ws/customers/smckeenews4/campaigns</id>
<title type="text"/>
<updated>2012-01-25T12:30:46:333Z</updated>
<author> <name/> </author>
<content type="application/vnd.ctct+xml">
<Campaign id="http://api.constantcontact.com/ws/customers/smckeenews4/campaigns" xmlns="http://ws.constantcontact.com/ns/1.0/">
<Name>asdFasdfasdf</Name>
<Status>Draft</Status>
<Date>2012-01-25T12:30:46:333Z</Date>
<Subject>asdFasdfasdf</Subject>
<FromName>Newsletter test 4</FromName>
<ViewAsWebpage>NO</ViewAsWebpage>
<ViewAsWebpageLinkText/>
<ViewAsWebpageText/>
<PermissionReminder>NO</PermissionReminder>
<PermissionReminderText>Permission Reminder</PermissionReminderText>
<GreetingSalutation>Dear</GreetingSalutation>
<GreetingName>FirstName</GreetingName>
<GreetingString/>
<OrganizationName/>
<OrganizationAddress1/>
<OrganizationAddress2/>
<OrganizationAddress3/>
<OrganizationCity/>
<OrganizationState/>
<OrganizationInternationalState/>
<OrganizationCountry>USA</OrganizationCountry>
<OrganizationPostalCode/>
<IncludeForwardEmail>NO</IncludeForwardEmail>
<ForwardEmailLinkText/>
<IncludeSubscribeLink>NO</IncludeSubscribeLink>
<SubscribeLinkText/>
<EmailContentFormat>HTML</EmailContentFormat>
<EmailContent>&lt;html&gt;&lt;body&gt;&lt;p&gt; aSD&lt;/p&gt; &lt;/body&gt;&lt;/html&gt;</EmailContent>
<EmailTextContent>Text Content</EmailTextContent>
<StyleSheet/>
<ContactLists>
<ContactList id="http://api.constantcontact.com/ws/customers/smckeenews4/lists/1"/>
</ContactLists>
<FromEmail>
<Email id="http://api.constantcontact.com/ws/customers/smckeenews4/settings/emailaddresses/1">
<link href="/ws/customers/smckeenews4/settings/emailaddresses/1" rel="self" xmlns="http://www.w3.org/2005/Atom"/>
</Email>
<EmailAddress>smckee@clinicapps.com</EmailAddress>
</FromEmail>
<ReplyToEmail>
<Email id="http://api.constantcontact.com/ws/customers/smckeenews4/settings/emailaddresses/1">
<link href="/ws/customers/smckeenews4/settings/emailaddresses/1" rel="self" xmlns="http://www.w3.org/2005/Atom"/>
</Email>
<EmailAddress>http://api.constantcontact.com/ws/customers/smckeenews4/contacts/1</EmailAddress>
</ReplyToEmail>
</Campaign>
</content>
<source>
<id>/ws/customers/smckeenews4/campaigns</id>
<title type="text">Campaigns for customer: smckeenews4</title>
<link href="campaigns"/> <link href="campaigns" rel="self"/>
<author> <name>smckeenews4</name> </author>
<updated>2012-01-25T12:30:46:334Z</updated>
</source>
</entry>

1 ACCEPTED SOLUTION
DaveBerard
Moderator

CAN-SPAM compliance requires all email marketing to have a physical address of the company sending the marketing messages.  If you notice, you do not have the require organization address fields set.  Setting those to a valid address should resolve that error.

Dave Berard
Senior Product Manager, Constant Contact

View solution in original post

2 REPLIES 2
DaveBerard
Moderator

CAN-SPAM compliance requires all email marketing to have a physical address of the company sending the marketing messages.  If you notice, you do not have the require organization address fields set.  Setting those to a valid address should resolve that error.

Dave Berard
Senior Product Manager, Constant Contact

View solution in original post

ShawnM641
Frequent Participant

Doh!

Developer Portal

View API documentation, code samples, get your API key.

Visit Page