The Community is hosting an End of Summer sweepstakes! Participants must complete tasks to earn tickets that will enter them with a chance to win a free year of Constant Contact and other great prizes!*
*No Purchase Necessary. For Official Rules, visit here. Constant Contact’s End of Summer 2020 Sweepstakes ends on October, 20, 2020 at 11:50 PM EST.

[SOLVED] Unable to change mashery password

SOLVED
Go to solution
Highlighted
Occasional Visitor

[SOLVED] Unable to change mashery password

Solved. There's a special link that pops up in Mashery after you fail to reset your password directing you to a different place to reset the password for older Mashery accounts.

---

 

I don't know where to ask this, but I'm trying to change my password for my CC API on Mashery and there is something wrong with the page. When I enter my updated password in both boxes and try to submit the form, I get:

 

  • Please correct the noted errors.
  • members[first_name]: This value is not allowed to be blank.
  • members[last_name]: This value is not allowed to be blank.
  • members[Developer_Type]: This value is not allowed to be blank.

Unfortunately there is no way to enter this information on the page. There's something wrong with this form, but there's no support link on that page to ask for help. Anyone have any suggestions on where to reach out?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Moderator

Re: [SOLVED] Unable to change mashery password

Hello,

 

Changes made to the developer account profile now require users to include their First and Last Name. After resetting your password, please add your name in your account profile so that  you can reset your password normally in the future.

 

Here is a direct link to the password reset flow for older accounts missing information in case anyone else needs it.

Please let me know if you have any other questions!

Regards,
David B.
Tier II API Support Engineer

View solution in original post

1 REPLY 1
Highlighted
Moderator

Re: [SOLVED] Unable to change mashery password

Hello,

 

Changes made to the developer account profile now require users to include their First and Last Name. After resetting your password, please add your name in your account profile so that  you can reset your password normally in the future.

 

Here is a direct link to the password reset flow for older accounts missing information in case anyone else needs it.

Please let me know if you have any other questions!

Regards,
David B.
Tier II API Support Engineer

View solution in original post

Developer Portal

View API documentation, code samples, get your API key.

Visit Page

Constant Contact 2020 End of Summer Community Sweepstakes!

The Constant Contact User Community is hosting a sweepstakes. The more you participate, the more chances you have to win! Read on to learn more...

Read More
Featured