cancel
Showing results for 
Search instead for 
Did you mean: 

SV_ADD Problems

Established Member

SV_ADD Problems

I have been updating my contacts through the SV_ADD API operation using a dataFile for the past few years.  I have added hundreds of contacts (sometimes thousands) without a problem.

Recently I started getting a system error when performing this operation.  I have discovered that there are three contacts that will always break the SV_ADD operation for me.  I can add a list of hundreds of contacts without an error, but then when I add in any one of these records the operation breaks.  Also if I include a dataFile with only one of these records, the operation breaks.  I am not sure that I publicly list the names and email addresses here or not, but I can send them privately to help trouble shoot this problem.

Each of these email addresses have been confirmed (my website sends out an email with a confirmation link that got clicked --- 2006, 2008, and 2009).   There is nothing that seems to set these emails or names apart from any of the other thousands that work.

The error message is always the same.  "A system error has occurred. Please try again."

Constant Contact support can take a look at my latest uploads in my Activity list to see what I'm talking about.  There are 3 "Add with Detail" activities that have a size of 1 with the described error.  To illustrate that I know how to to properly format an upload, there is an "Add with Detail" activity with 1642 records that completed with no errors.  Then I inserted one of these bad records into the same list, and can see an "Add with Detail" activity with 1643 records that fails.

Has anyone else experienced this problem?  Can anyone tell me why this might be happening?  If I could know what the offending records might be on inspection, that would be great.  Unfortunately I had to spend hours trying to isolate these bad records by hand.

Best Regards,
Shannon

2 REPLIES 2
CTCT Employee

Re: SV_ADD Problems

Hi Shannon,

 

It does sound like you are experiencing a defect that our team is working to resolve.  Certain email addresses are not able to be added to accounts, or sometimes, just specific lists within accounts.  (If you wanted to work around the issue, you might be able to create new lists in the account and add your contacts to those.)  

 

I may also be able to get those email addresses reset for you if you email us the email addresses that are causing the issue--just email webservices@constantcontact.com with the username of your account and the email addresses that are causing the issue.  I am sorry for the inconvenience.

 

Thank you for contacting Constant Contact, and have a wonderful day!

 

Best Regards,

Shannon W.

API Support Specialist

Established Member

Re: SV_ADD Problems

Thanks, Shannon.  I have sent the email addresses to webservices.  Hopefully that will do the trick.