cancel
Showing results for 
Search instead for 
Did you mean: 

Support Ending for TLS v1.0 and v1.1- Immediate Action Required

Moderator

Support Ending for TLS v1.0 and v1.1- Immediate Action Required

The Constant Contact API, managed by TIBCO’s Mashery, will no longer support TLS v1.0 or v1.1 when establishing secure connections as of September 30th, 2018. We recommend updating your integration to TLS version v1.2 to comply with security practices outlined by the Payment Card Industry (PCI) Security Standard Council.

 

Please visit our Tech Blog to read our full article.


Regards,
Jimmy D.
Tier II API Support Engineer
2 REPLIES
Frequent Participant

Re: Support Ending for TLS v1.0 and v1.1- Immediate Action Required

Hi Jimmy,

 

I'm using the only PHP library listed on your site: https://github.com/constantcontact/php-sdk. I've also been listed as a developer account not running through TLS v1.2 as noted in your post. 

 

Is there a solution for people like me? 

 

Jason

Moderator

Re: Support Ending for TLS v1.0 and v1.1- Immediate Action Required

Hello Jason,

 

Our SDKs are libraries that make it easy for you to make calls to our API. The calls themselves are run from your server with your own framework, so there is no update needed to the SDK directly. Because each web server and application is different, I'm not able to provide you with specific directions on how to make sure everything on your server is up to date. I would recommend reaching out to your hosting provider for detailed steps on how to check or upgrade your TLS compatibility.

 

Sincerely,
David B.
Tier II API Support Engineer

Still need help?
You can post a new message in the Community or find us on Twitter Mon-Fri 8am - 8pm ET. We've got real people waiting to help you out. Click below to start a conversation!