Highlighted
Occasional Participant

WElcome Email Not Sending!

Hey All,

 

My contacts are being added to the correct list but they are not receiving any welcome emails or autoresponders. Does anybody else have this same problem? What can I do to fix it? Please help!

 

Thank you!

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Trusted Contributor

Re: WElcome Email Not Sending!

Hello,

 

If you're contacts are being added using a signup form that uses our API, it's likely that your form is submitting the contacts with the Opt-In source specified as "ACTION_BY_CUSTOMER."  In order for the Welcome email for your account to send to contacts, the contact data should be submitted with the OptinSource element's content should be "ACTION_BY_CONTACT" instead - see our Create Contact Documentation.

 

I hope this helps.  Let us know if you have additional questions.

Mark Coleman
Support Engineer

View solution in original post

6 REPLIES 6
Highlighted
Trusted Contributor

Re: WElcome Email Not Sending!

Hello,

 

If you're contacts are being added using a signup form that uses our API, it's likely that your form is submitting the contacts with the Opt-In source specified as "ACTION_BY_CUSTOMER."  In order for the Welcome email for your account to send to contacts, the contact data should be submitted with the OptinSource element's content should be "ACTION_BY_CONTACT" instead - see our Create Contact Documentation.

 

I hope this helps.  Let us know if you have additional questions.

Mark Coleman
Support Engineer

View solution in original post

Highlighted
Occasional Participant

Re: WElcome Email Not Sending!

Thanks for the reply! I am trying this now! I'll update

Highlighted
Occasional Participant

Re: WElcome Email Not Sending!

It worked! Thank you so much for your help!

Highlighted
Occasional Contributor

Re: WElcome Email Not Sending!

Could you put these directions in plain English please? I'm sorry, but I have no idea what youare talking about! I went to the link you shared, and I have not idea how to use that either.  I'm not a data entry tech person, evn though I can figure out most problems. 

 

Thanks!

Highlighted
Moderator

Re: WElcome Email Not Sending!

Hello,

 

You are replying on a post on our developer support forum for software developers building integrations with our API. In this instance, contacts were being added via a form that uses our API but it was set up in such a way that matches adding contacts from within the Constant Contact website, which does not trigger a welcome email to send. The solution was to set it up so that Constant Contact is being told that it is the owner of the email address themselves that is taking the action, which does trigger a welcome email.

 

If you have questions about the Welcome Email or Autoresponder campaigns not sending in general, please reach out to our main support team at 866-289-2101, or by emailing support@constantcontact.com.

 

Sincerely,

 

David B.
API Support Specialist

Highlighted
Occasional Contributor

Re: WElcome Email Not Sending!

Thanks, David!  I'm in touch and going to be talking to the A/R team about how my A/R is getting triggered to shut down.

Developer Portal

View API documentation, code samples, get your API key.

Visit Page

Meet the New Constant Contact

ctct_ripple_logo_icon_blue_orange.pngConstant Contact is Bigger. Better. Smarter. Check out our new look and Power On!

 

Read More
Featured