cancel
Showing results for 
Search instead for 
Did you mean: 

adding contacts through the API not showing up

Occasional Contributor

adding contacts through the API not showing up

I have a program that adds contacts from our database using a Json object and I am not getting any error messages, but the contacts are not showing up.

 

Json object: 

"{\"import_data\":[
 {\"email_addresses\":[
  \"zstuff@mac.com\"],
 \"first_name\":\"Joe\",
 \"last_name\":\"Botana\",
 \"home_phone\":\"\",
 \"work_phone\":\"\",
 \"addresses\":[
  {\"address_type\":\"PERSONAL\",
  \"city\":\"\",
  \"country_code\":\"US\",
  \"line1\":\"\",
  \"line2\":\"\",
  \"postal_code\":\"\",
  \"state_code\":\"\"}],
 \"custom_fields\":[
  {\"name\":\"Membership Level\",\"value\":\"\"},
  {\"name\":\"Chapter\",\"value\":\"\"},
  {\"name\":\"customfield3\",\"value\":\"1\"}
  ]},
 {\"email_addresses\":[
  \"zoysite@gmail.com\"],
 \"first_name\":\"Christa\",
 \"last_name\":\"Laser\",
 \"home_phone\":\"\",
 \"work_phone\":\"\",
 \"addresses\":[
  {\"address_type\":\"PERSONAL\",
  \"city\":\"\",
  \"country_code\":\"US\",
  \"line1\":\"\",
  \"line2\":\"\",
  \"postal_code\":\"\",
  \"state_code\":\"\"}],
 \"custom_fields\":[{
  \"name\":\"Membership Level\",\"value\":\"\"},
  {\"name\":\"Chapter\",\"value\":\"\"},
  {\"name\":\"customfield3\",\"value\":\"1\"}]}],
\"column_names\":[
 \"EMAIL\",
 \"FIRST NAME\",
 \"LAST NAME\",
 \"HOME PHONE\",
 \"WORK PHONE\",
 \"CITY\",
 \"COUNTRY\",
 \"ADDRESS LINE 1\",
 \"ADDRESS LINE 2\",
 \"Zip/Postal Code\",
 \"STATE\",
 \"CUSTOM FIELD 1\",
 \"CUSTOM FIELD 2\",
 \"CUSTOM FIELD 3\"],
\"lists\":[
\"1145431831\"]}"

 

and the response string:

"{\"id\":\"5e86a450-936d-11e7-b88f-d4ae5292c426\",\"type\":\"ADD_CONTACTS\",\"error_count\":0,\"contact_count\":2}"

 

Can you see what might be going wrong?

 

Thanks,

rg

6 REPLIES 6
Moderator

Re: adding contacts through the API not showing up

Hello,


Thank you for reaching out to the API Support team here at Constant Contact.

 

The response seems to indicate that the contacts were added successfully. Can you please send an email with your Constant Contact account username to webservices@constantcontact.com so that we can look into this for you further?

 

Sincerely,
David B.
API Support Engineer

Occasional Contributor

Re: adding contacts through the API not showing up

In a separate email I provided the requested information but I have not heard back.  Is there anything more I can do to help out?

 

Thanks,

rg

Moderator

Re: adding contacts through the API not showing up

Hi @NicoleM504,

 

My coworker David sent a reply to Randy on 9/8/17 at 4:24pm. The email address used was the same email address that was used to create the case with webservices@constantcontact.com. I do not want to give that email address out a public forum, but if you would like me to send this to another email address I am happy to do so. I can also put that reply here, but as it contains the username of accounts that is not recommended.


Regards,
Jimmy D.
Tier II API Support Engineer
Highlighted
Occasional Contributor

Re: adding contacts through the API not showing up

I sent all the info.  based on your reply to that I changed the account I was using, changed the api key and access token and still got the same results.  I am at a loss!  tried reaching out to web support by email and phone call and received no play to email and was told webservices has no phone to transfer call to.  so I am stuck with a **bleep** off client, **bleep** off manager and no place to turn to to get a solution!

 

rg

Moderator

Re: adding contacts through the API not showing up

Hi @NicoleM504,

 

We have replied multiple times to the case that was created when Randy emailed us at webservices@constantcontact.com. While it is true our department does not have a phone line to call we are here to assist you through email. Please reply back to the last email we sent from the case and let us know what is going on and we will continue to assist. Let us know which API Key you want to use and which Constant Contact username you are trying to add contacts to and we will verify the Access Token that should be used.

 

We are also happy to assist here if you would prefer; however due to the nature of the issue that would require us to discuss usernames and email addresses which are generally better to keep off a public forum.


Regards,
Jimmy D.
Tier II API Support Engineer
Occasional Contributor

Re: adding contacts through the API not showing up

Thanks for the additional help.  Your suggestions did the trick!

 

Thanks again,

rg