We all started somewhere! Share your experience on the Get Advice: Let's Get Started Sweepstakes thread and be entered to win a $100 credit on your Constant Contact account.

Browser

DonP45
Participant

Browser

I seem to have problems lately with Google Chrome. I get the index page but any request to login results in a blank screen. Microsoft Internet Explorer seems to work OK though, so I'm good to go.
1 REPLY 1
Caitlin_M
Administrator

Hello @DonP45. I'm sorry that you're having trouble with your browser, specifically with Google Chrome. I have a few troubleshooting tips I would like to offer:

 

  1. Try to log in using login.constantcontact.com. This will bring you right to the login page.
  2. Close your browser out completely and open a new browser window. Sometimes all the browser needs is a refresh in order for it to work properly!
  3. Use an incognito or private window. If you are able to access your account using an incognito or private window, then there might be an issue with a third-party plugin. Please see this FAQ for more information on disabling plugins.

Caitlin M.
Community Manager
Did I answer your question? If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.

You're not alone on your email marketing journey. Connect with a Marketing Advisor to see how they can help you develop the right strategy for your business and get the most out of your Constant Contact experience.