Formatting issue - email does not look like preview.

SOLVED
Go to solution
Occasional Participant

Formatting issue - email does not look like preview.

I'm having major difficulties getting the format in my meeting invite correct.  I always spend too much time changing font sizes and adding spaces only to have them revert or change to something completely different a couple of saves down the line.  The text editor has a mind of its own!  However -  the big issue is the resulting email.  Once I get the email looking the way it should in the preview, I send out a test email and open it in Outlook and its all jacked up again. 

 

How do I fix this?  I can't send the current email out to colleagues without looking like a moron. 

 

Thanks,

Shelley Broyles

1 ACCEPTED SOLUTION
Marketing Advisor

Hi there, 

When using our Second Generation Editor (2GE) sometimes what you are designing may not be the same design and layout that gets sent out to your contacts.

 

Email programs and mobile devices have unique ways of displaying emails. So, the email design your contacts see may not exactly match what you see when you preview it in Constant Contact which I know can be frustrating. These issues typically arise when you are copying an email multiple times as the HTML code for all of your edits from previous versions may cause these display issues. We recommend creating a new email, in this case, to make sure that you are starting fresh. If you use the same layout for all of your emails you can use the Save as template feature so that your edits to the design of the email will be saved and you can still create a new email to help avoid any display issues. Here’s more info on that.

 

Please see this FAQ with these design tips and you can make your email look better in all email programs (Outlook, Gmail, Yahoo, etc.):  http://conta.cc/2lkiaQZ

Always preview your email before sending whether you are using 2GE or 3GE.  I hope that helps! 

 

 

View solution in original post

575 REPLIES 575

I struggle with this same problem, and not just with photos. Why does my newsletter look okay in the preview, but when it is emailed, it looks totally different? Spacing, etc. is way off.

That happens to me all the time. I was told it has something to do with Microsoft Outlook.

Folks, Many times this is an email client rendering issue an not a CC one. First question to all of you is, are you creating your work as custom HTML or using the CC templates? If you're using HTML do you test the output in a variety of email clients such as Outlook, Yahoo, Gmail, AOL, etc? If so do they look malformed in all or just a subset of them? Regards, Tony

All browsers and email programs have default settings that can change the appearance of your email, whether it is Constant Contact or any other program. Some have restrictions on images, fonts or width of the email. Outlook 2003 has different defaults than 2007 and 2010. AOL has restrictions on some image sizes. Emails view differently on Internet Explorer than Google Chrome (so do websites). For this reason I test all my clients' emails in several browsers and email platforms and then use a template that works best in all of them. Wishing you success.
Puzzle Master, Solutions Consultant
Specialist Web Accessibility
Solutions & Support for the solopreneurs; small and mid-sized companies.
Publisher, Author, Speaker

Solutions, not just answers.
One Size does NOT fit all.
Regular Participant

Many thanks for all your comments, it would seem its a browser problem - its very annoying and time consuming - I do check the previews in different emails, ie microsoft outlook and hotmail, I am not sure there is an easy solution now.
Regular Participant

I've noticed (with increasing frequency) major difference between viewing an email in Outlook, as a web page, in Hotmail and in Yahoo!.  Text may be aligned differently, different colors, and even different sizes.  When looking at the code, it all appears correct, yet I can't figure out how to make it look consistent for all email providers.  Any suggestions?

Outlook renders differently from web based email clients - Outlook 07 won't render many tables or special characters correctly - it will also show all images in their original sizes - I get around it by keeping things simple, bullets, bold, italics, with relevant images tossed in
Occasional Participant

My email looks the same in Thunderbird, Mac Mail and Outlook Express but colors change in Outlook. Does anyone know how to fix that? For example, I have a light beige background with dark green text but in Outlook the beige turns to dark green, making my green text almost unreadable.

Thanks for any info you can give.

Annette
Regular Participant

I'm having the same issue, and the frequency is increasing. I try to pick new templates (rather than re-using/updating an email) and still get those issues. It doesn't make sense even if you look at the code and unfortunately it seems to be an issue Constant Contact can't fix because it's a "Microsoft issue."
Occasional Participant

I have noticed that when I send out longer messages (about 2 or more printed pages) that a line appears when viewing the message in Outlook. The line has shifted text so that at least one or two lines of the message is unreadable.

I create all my messages in html and don't use complex formatting (paragraph tags with some bold and italics thrown in).

Is anyone else seeing this issue, and if so have you found a remedy?
Occasional Participant

I forgot to mention that this issue only seems to appear in Outlook.

Jim, Outlook uses the MS Word HTML rendering engine and you might be picking up a problem with it. Does it break in the same spot all the time? If so try putting in some while space or page breaks. Perhaps you can make a PDF out of the email and place a link to it from your newsletter. That way you could use what ever formatting you wanted and not be restricted to HTML either. Regards, Tony
Occasional Participant

preview email is different from sent product

Dorothy, Can you be "a lot" more specific? Whats different, what are you looking at your email in? GMAIL , OutLook? Regards, Tony

sorry, what I do is look at the finished product in constant contact login from yahoo? then I email a finished product to myself and get a different product. I am viewing it in yahoo att mail.

I am experiencing this EXACT same issue. I work with constant contact while using Mozilla Firefox. I alter the code to my liking, adding background images in the style sheet and everything works fine. When I send myself a test email in firefox it opens flawlessly! But, however when I read that SAME exact email in another browser like Internet Explorer 8, the images do not show (just the image box) , the css code for the background images does not seem to work either. It is VERY annoying because how am I to know how many of my contacts actually use IE over firefox?

Further tests show that when I use an image that I have linked to does now show. But if it is hosted on Constant Contact the email works in both browsers
Regular Participant

Is anyone else having issues with the background colors in the email? We have been getting numerous complaints from readers saying that they are getting an email with a blue background and then the links are blue so it is difficult for them to read. First of all we have the main text boxes set to have a white background and this happens even when the rest of the background is not a blue color. Any thoughts on why this might be happening?

Thanks!

Not sure if you're using your own code or a CC template. Some clients most notably Microsoft Outlook are problematic with background colors. If there is no reference to blue anywhere in the piece its a bit hard tracking down the cause. I think there's something going on that your missing somehow. Take the HTML from the newsletter and look at it in your HTML editor to see if you can discover the reference to blue. In addition to that you should also be able to control that active link and make it a color other than blue if you wish. Regards, Tony

Check your template. Some have a white background image but will have a different background color underneath. If the email program you are using does not support BG images (such as Outlook 2007+), the BG color will display instead. This could be the source of blue background. You can check this in the "Global Colors and Fonts" section of the email editor. If you see a "Use no image" option, click it and see what happens (just don't save your changes unless you like the outcome). - Steve
Regular Participant

I have formatted an email, and have sent it to various people in Preview to test. One person receives it in a totally different format (text is not formatted the same) than another. Both recipients have the same screen resolution. Why would the format appear different (ugly) for some and appear as I formatted it for others?