In recognition of Martin Luther King Day, our Support Centers will be open with limited hours on Monday (1/18) from 10AM ET to 6PM ET. Visit our Help Center to see all of the ways you can find answers to your questions.

Formatting issue - email does not look like preview.

SOLVED
Go to solution
Occasional Participant

Formatting issue - email does not look like preview.

I'm having major difficulties getting the format in my meeting invite correct.  I always spend too much time changing font sizes and adding spaces only to have them revert or change to something completely different a couple of saves down the line.  The text editor has a mind of its own!  However -  the big issue is the resulting email.  Once I get the email looking the way it should in the preview, I send out a test email and open it in Outlook and its all jacked up again. 

 

How do I fix this?  I can't send the current email out to colleagues without looking like a moron. 

 

Thanks,

Shelley Broyles

1 ACCEPTED SOLUTION
Marketing Advisor

Hi there, 

When using our Second Generation Editor (2GE) sometimes what you are designing may not be the same design and layout that gets sent out to your contacts.

 

Email programs and mobile devices have unique ways of displaying emails. So, the email design your contacts see may not exactly match what you see when you preview it in Constant Contact which I know can be frustrating. These issues typically arise when you are copying an email multiple times as the HTML code for all of your edits from previous versions may cause these display issues. We recommend creating a new email, in this case, to make sure that you are starting fresh. If you use the same layout for all of your emails you can use the Save as template feature so that your edits to the design of the email will be saved and you can still create a new email to help avoid any display issues. Here’s more info on that.

 

Please see this FAQ with these design tips and you can make your email look better in all email programs (Outlook, Gmail, Yahoo, etc.):  http://conta.cc/2lkiaQZ

Always preview your email before sending whether you are using 2GE or 3GE.  I hope that helps! 

 

 

View solution in original post

575 REPLIES 575

Michelle, Can you share a little more. Are you using the CC templates or some HTML code? Testing in different browsers and different mail clients is something that goes by the casual users of the system. Perhaps you have found a bug or perhaps its something that you might be overlooking. What do you mean text is not formatted the same? These are specific questions because troubleshooting gets specific. A great resource is the CC hotline. Regards, Tony

In reponse to the post from Clique Marketing: I am using CC templates. Standard code - nothing custom. In the email, I have text to the left of an image (both in same box). The person that has reported the display issue has their computer set up for same resolution as I, and we are using the same browser and versions of Outlook (we work for the same company). Both received email from CC. When this person sees the email, the text (to the left of the image) is displayed in a more narrow border than what I have it formatted as, and therefore, is displayed incorrectly down the left side of the image. The image on the other hand, looks to be same size - and is displayed fine. If I forward my properly formatted email from CC to them, they see it fine. So it's just when sent directly via CC. I am concerned that there are other email recipients receiving this incorrectly (but not telling me...)!
Occasional Participant

When I set up an e-mail I have the article text in black. When the e-mail is sent and received by the public it comes over as white text. Why? I verified that the text is formatted as black.

Where are YOU checking with and where are THEY reading with? It's a good practice to check your output in as many email clients and MSP systems / browsers as you believe makes sense. For instance a rule of thumb would be always check in Outlook 2003 and 2007, Hotmail, Gmail and Yahoo as that represents the lion share of email clients. Regards, Tony

I have had the same problem. If I format in one color and then do the preview it often times has changed colors. I would love find a solution as I spend way to much time fixing things.

I have the same problem, but it doesn't just end with text color for me. Soemtimes, random lines will get indented and sometimes text size will change. I've mitigated the problem a little by making sure I change the text color in the global fonts and colors (left column when youre in edit mode) and by not copying and pasting anything (even text stripped through TextEdit or Notebook). But I still have a lot of issues. It makes my emails look so unprofessional. I have been doing what Clique Marketing suggested, and it's shocking how inconsistent the emails look after sent. Browsers and email servers all have an effect on the final product. I called to ask about it, and the support girl told me it's a problem they've had for a long time, and there's nothing I can really do about it.

Occasional Participant

I've just started using the HTML functions for creating emails. In sending tests to multiple ESP accounts, everything works fine except for Outlook. The emails I receive in Outlook are not visible nor are they functional. Big blank screen with the usual ConstantContact information and logo - which is fully functional below.

What am I doing wrong???

Both the email address and domain are saved on my safe list. Outlook is not prompting me to click to reveal images (Google and Hotmail are). 

There is no indication that links and images are disabled. Just a large blank area where the HTML code is.

The standard CC prompt to "view" the online version of the email is at the top. Clicking on the link shows a fully functional email.

Any help?

Scott, Outlook 2007 is historically crabby. It renders its HTML with the MS Word engine and not IE as previously done with OL 2003. You'll need to spend some time working through that and learning to code to the weakest link, which is usually OL 2007 For starters all your CSS needs to be inline, many of the form background options don't work. With OL 2007 its the KISS and TEST rule. Regards, Tony

I just was talking to someone about this very issue and gave him this advice (which, after 24 hours of crying and rocking back and forth in a corner of my office i finally figured out) !!!Remove the head tags in your code!!! I did this and voila! HTML rendered "properly" (as in images and styles appeared.. not perfect but a huge leap forward from yesterday when i was seeing nothing at all)

Regular Participant

every time i create an email, there are problems.  this is so frustrating i could cancel my account.
Regular Participant

sorry, in my frustration i forgot to reread for spelling errors...

you are probably importing your own html and I was told email html is a little different so the code needs to be adjusted. I am having the same problem

Occasional Participant

I'm having the same issue. I'm not importing code but using their useless wisiwyg editor...it looks fine when I build it but when I send it to myself it changes font sizes, bolds items, every line is a little off ...I feel your pain and hope that you fix your problem. I'm really close to abandoning ship. I could see if only a few people were having issues but reading so many problems - how could so many people be having the same problem?

Coding HTML to work with email is one of the WORST tasks ever. It is probably the most tedious thing i've ever done so don't give up! Is html just not rendering at all? If so, remove your header tags. After a full day of pulling my hair out, i noticed none of the templates CC offers have header tags in them. So i removed mine and voila. HTML rendered. You might possibly want to blame your email provider. Currently i'm struggling with this issue. Outlook inserts bizarre spacing between my table rows, hotmail doesn't render images properly, etc.. Unfortunately i haven't found a solution for no 2 yet. And I'm tearing my hair out over it. But at least i think i've narrowed down the problem.

Occasional Participant

I have built an HTML-based email in Dreamweaver that includes a centered body. When previewing via the advanced editor in Constant Contact, the email body remains centered and looks great.

However, when I send a test email, the body is left justified while the constant contact information above and below remain centered. How can I force the HTML I created to stay centered.

I have tested this in Outlook and Gmail with the same issue.

Make sure your html is in agreement with the CSS settings.

Puzzle Master, Solutions Consultant
Specialist Web Accessibility
Solutions & Support for the solopreneurs; small and mid-sized companies.
Publisher, Author, Speaker

Solutions, not just answers.
One Size does NOT fit all.

What exactly do you mean by this?

That's not an answer. CSS settings are in agreement the moment you set up the page in Dreamweaver.  You cannot have an image (or a block of HTML) un-centered and have it's CSS designation say "centered".   Not possible.

 

I have the same problem.  Centered in the preview, but not in the actual sent email.

 

If the preview is showing the HTML correctly, then the emails should follow suit.

 

I SMELL A BUG!!!!

Hi Brent,

Sorry to hear this is happening. Since this is a bit of an older thread I am happy to take a look. What is the name of the email you are working on and what email client are you sending to?

 

Thanks,

Hannah M.
Community and Social Media Support

If you find my post helpful, and it answers your question, please mark it as an Accepted Solution

Are you on Twitter? Follow me here!
Regular Participant

I added a table of contents box to my e-mail. When I'm previewing in CC, the TOC looks perfect. When I send a test e-mail to myself, extra line breaks show up in the TOC box. I don't know how to work on this since I can't see the HTML for the TOC box.

Any ideas? I've uploaded pics to show what I'm talking about.

I have the same problem and was told by CC that it's an Outlook 2007 issue.