Link Not Working

SOLVED
Go to solution
TracyD5191
Participant
I am trying to send out an email campaign using PDF documents with an imbedded link for recipients to register for an event.  I tested the link in the original PDF document prior to downloading it to Constant Contact, and it works.
 
BUT, when I bring that document into Constant Contact, the link functionality gets removed.  So I selected the section of the email where the link should be and added it back in.
 
TracyD5191_0-1668180697105.png

 

However, when I click on the link from the Preview in Constant Contact, and from the test emails (both personal and business) I sent myself, the link functionality is not working properly. It seems the original link is being hijacked by spam sites, and in some cases just goes to a blank Google page.  I tried multiple times, and was directed to multiple different spam sites.
 
The link I'm using is valid.  And this is not an issue with my company controlling Internet settings since it's also happening in my personal email.
 
I would really appreciate some assistance with getting this working since it's critical to my campaign.
 
Thanks!
1 ACCEPTED SOLUTION
William_A
Moderator

Hello @TracyD5191 ,

 

The issue is that you have an extra l before the dot. Your site should be bit.ly , not bitl.ly - that's what causing it to look (and probably be) very suspicious to your browser. When I corrected this error when pasting your URL into my address bar, your site loaded as expected.


~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
William A
Community & Social Media Support
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Did I answer your question? If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.

Anyone can be a marketer! Visit our Blog & Resources page to brush up on the latest tips and tricks.

View solution in original post

2 REPLIES 2
William_A
Moderator

Hello @TracyD5191 ,

 

The issue is that you have an extra l before the dot. Your site should be bit.ly , not bitl.ly - that's what causing it to look (and probably be) very suspicious to your browser. When I corrected this error when pasting your URL into my address bar, your site loaded as expected.


~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
William A
Community & Social Media Support
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Did I answer your question? If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.

Anyone can be a marketer! Visit our Blog & Resources page to brush up on the latest tips and tricks.
TracyD5191
Participant

Ug, I thought I had triple checked everything before posting.  Thank you for your quick response!!

  • Support Tips

    Reporting Metrics

    "Authenticating your emails is the best way to ensure your emails achieve maximum deliverability. If you have your own domain, setting up self-authentication is especially important! " - Will

    See Article
    Avatar
  • Support Tips

    Call-To-Action Links

    "Target your most engaged contacts by creating a segment. Create a special offer or show your appreciation!" - Caitlin

    See Article
    Avatar
  • Support Tips

    Read Before You Send a Test Email

    "Did you know? You can send unlimited test emails to your verified email address, but only 50 in a 24-hour period to non-verified email addresses." - Nick

    See Article
    Avatar