Logo bug

Regular Participant

Logo bug

I was updating our organizations' logo and discovered what seems to be a bug. If I try to change the image and use my image library, it doesn't include the URL, which causes an error. The only way to do this currently is to instead go to the library tab, click on the link under basic info, ignore the URL, ignore select, right-click on the image, select "open in new tab" and copy that URL. I'm thinking there must be a simpler way to do this. (Using Chrome on a PC)


Hello @KenS1,

Thank you for contacting us! 


I am sorry to hear about the issue you are experiencing with your logo. Have you tried opening Constant Contact on another browser to see if that fixes the issue? Also, sometimes using Incognito/Safe Mode will reveal that it might be a plugin/extension that is interfering with the site. If that does not work please email us at social_support(at)constantcontact(dot)com with your username, the troubleshooting steps you have tried, and a reference to this post so that we can investigate it further.


Thank you!

Community & Social Media Support

If you find my post helpful, and it answers your question, please mark it as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.

Increase your profitability by integrating your email marketing and social media.  Download this guide and learn how you can achieve great results with email marketing and social media combined!