Missing images in emails sent out - still happening as of 4/1/21 - any solution?

IconKoolTrends
Participant

Missing images in emails sent out - still happening as of 4/1/21 - any solution?

We just sent out a CC eblast consisting mostly of an image - which does not show up in Windows recipients' email. The test emails - sent to a Mac user & Mac recipients showed up fine, but not for Windows people.

 

I saw lots of other peoples' complaints about the very same problem  - dated about a month ago. The upshot of those complaints is that it is a problem on CC's end.  Why is this still an issue a month later?? Is there something we can do on our end, or is CC still working on it? 

 

Please let us know if you have any information about this issue. Thanks!

 

1 REPLY 1
Mary_S
Employee

@IconKoolTrends 
I apologize your images are not being seen by all of your recipients of your campaigns. Let me gather a bit more specific information so that we can check to see if there is anything we offer to improve the Windows users experience.
* Do you happen to know what email client the Windows users are  using? (For example Outlook 2010)

* What is the name of a campaign or campaigns where you have noted the missing images?

If you could email communitysupport(at)constantcontact(dot)com with the information requested, we will investigate further.

 



Mary S.
Community & Social Media Support

Did I answer your question? If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.

You're not alone on your email marketing journey. Connect with a Marketing Advisor to see how they can help you develop the right strategy for your business and get the most out of your Constant Contact experience.