In recognition of Martin Luther King Day, our Support Centers will be open with limited hours on Monday (1/18) from 10AM ET to 6PM ET. Visit our Help Center to see all of the ways you can find answers to your questions.

Reporting Page not Loading

Reporting Page not Loading

Day 2 of my Trial and I am having problems loading the Reporting Page. It half loads and then stops. Also, created coupon for Facebook and it's not showing properly in Apps.  Also the 'Join My List' App in Facebook is requesting people to join Constant Contact and not my email list that doesn't seem right.  So far, doesn't seem to be working very well for me.  Please advise.




I'm sorry to hear of the trouble you are experiencing. I hope I can help you.


I took a look in your account and I see that your coupon is in draft mode. Reporting will not be available until you publish your coupon and once you publish you will be put into a paid account. Right now you have the default page under "Coupon" that just allows for people to join your list.  For the Join My List app, that is not properly set up yet. You will have to set that up under your personal account, not under your business account.


Here is our FAQ on how to set up the Join My Mailing List app on your Facebook page.


I hope that helps! For immediate assistance, please reach out to our phone support team at 1-866-289-2101.




Has anyone had an issue with campaign reports missing. I mean that the whole report is not in the reports section for campaigns. The issue seems to be getting worse as we have no reports for the last three days. Prior to that they were showing up randomly

It has been reported and CC says they are aware but I can't find anyone else mentioning this. I need to call and level 2 support has to email me the link to the reports.

Has anyone had this issue? A solution/workaround?

Thanks in advance,


Thanks for reporting this to the users.

Hi @arthurF46 


Thanks for posting in the User Community. I see that you have an open case with our Specialists to help you out with the missing information.


I apologize that you are affected by this. Please let us know if there's anything else we can assist you with!

Yes! I have this issue every 6months when I go to do all our reporting. Then I have to wait for the call centre to open at 6pm my time, as I am in Sydney, Australia. Once I speak to someone, it is fixed quickly, however the fact it occurs every time is absolutely infuriating. Unless someone has a work-around, I think I'll just switch over to .


Hello: The campaign I launched last night has zero opens and clicks. I have done several prior campaigns emailed to the same group of people and all had many opens/clicks at this point. Is there are problem with tracking? Thank you very much. Jason Ryan

Hi @JasonR477 


Thanks for letting us know that you were affected by this. This was due to our website being down on the 5th. This has all been resolved and I see that you do have reports for your campaign.


If you have any questions or are not seeing this information please let us know!


Site is up, I see the main tabs on the website, but everything else will say it's loading. and won't ever load.

Hi @CassieC31 


I'm sorry to hear that you were having difficulty getting the full page to load while you were in your account earlier today. I was able to log into your account with no trouble and all the information did display for me. It looks like you were using Safari and I wanted to ask you a couple questions as well as provide you with some troubleshooting steps in order to help.


Were you able to access any pages of your account after you posted this?

Did you try any other browsers and if so, which ones and were they successful?

Are you able to try with using Incognito Mode, Safe-Mode, or Private Browsing in your browser? (instructions in link below)


Here are some steps that can help you optimize your browser.


Please let me know so that our team can best assist you!

Occasional Participant

When utilizing the "reporting" feature or attempting to "resend" a newsletter, I get a "request for entity to large" and my icon continues to load and load. After leaving my computer running and walking away, it still is does not load. I have less than 2000 contacts. I did not have this issue originally during the test trial. Any help or support is greatly appreciated.

This is an ongoing bug they have been trying to address for some time.


Try downloading FireFox and using that as a test.  Let us know how you make out.



Thank you!  This did the trick and I am able to utilize CC as it was intended. 



What is the Firefox solution??


When can we expect a real fix?  So frustrating that I will likely leave Constant Contact for another better tool.

Hi @EdwardE782

I am sorry that you are running into this, are you only seeing this message when trying to resend? If so, some users have found success in working in another browser (and/or clearing cache) but the alternative is to copy the email and send it to the people who are new. 


I don't have a timeframe to share for a resolution but the engineering team is working on this. I would be happy to leave your case open to have you notified when this is resolved if you would like!



Hannah M.
Community and Social Media Support

If you find my post helpful, and it answers your question, please mark it as an Accepted Solution

Are you on Twitter? Follow me here!

I sent an email on 2/27, and received an email with my preliminary results. But when I click on reporting, there is no data. When I click on the report from my email, I can get to a report that shows sent, bounced, undelivered, and unopened data.

Hi @JohnS1260


Thanks for posting! I just took a look at your account and saw that you were able to connect with a support representative through chat who was able to help you with your question about the reporting. Did you get the answer you were looking for or did you still need some assistance with this? Please let us know and we'd be happy to help!

Natalie B.
Social Media Marketing Manager
Occasional Participant

None of my reporting features have worked in over a week. Please resolve this issue soon; reporting is a huge part of my job and it's hard with almost no visibility.

Hi @AmandaS967


I'm sorry to hear about the issues with the reporting. What happens when you try to get your reports? Does the page freeze or is there an error message? Does it occur if you access the Constant Contact site using a different browser? I'd appreciate any other details you can offer about what happens so that I can help troubleshoot this for you. Thanks!

Natalie B.
Social Media Marketing Manager
Occasional Participant

I get a message saying "We're sorry, but something went wrong". It occurs when I use different browsers; I've even tried using different computers in my office and I have the same issue. I've had this problem for about a month, prior to this I had no issues.


I also have tried sending several campaigns, but on my end they still appear in draft mode although I have received the campaign myself. This is an issue because I have absolutely no reporting visibility and cannot be sure the email was sent to everyone.

Hello @AmandaS967


Thank you for giving us this information.  This is an issue that we are working to resolve currently.  There is a workaround that some customers have used that has worked to be able to view the reporting.  You can choose to delete the emails so that they go to your Deleted folder.  You should then be able to view the reporting for your campaigns.  Please note, that by deleting the campaign it will break any links to the campaign if you have shared the Short URL for the campaign.  You can always restore the campaign from the deleted folder as needed though.  If you would like I can put in a request for you to be notified when this issue is resolved.