Segment criteria "does not have tag" doesn't seem to work

Occasional Participant

Segment criteria "does not have tag" doesn't seem to work

So I created a segment for "did not open any email for 2 yrs" using my "general interest" list and got 27 hits. Then I ran the same query but added the criteria that the people had to have the tag "members" and got 13 hits. 

But when I try to change the criteria to does not have the tag "members" I got NO hits. Why did I not get the other 14 people who are not tagged as "members"?

I know that I could manually delete the 13 members from the list of 27 but I would have thought that the system could do that for me.

My goal is to send "reconfirm" email to the non-members who don't seem to be opening emails but I don't want to send that kind of email to members who will stay on the mailings even if they never open an email.

1 REPLY 1
Moderator

Hello @RobertF208 ,

 

Our higher level technical team and I were able to recreate the issue. At this time, we don't have much insight, so I submitted your case to them for further investigation. They will follow up within the next four business days to the primary email address on the account, and continue the investigation or create a new service request from there.

 

Thank you for bringing this to our attention!


William D
Community & Social Media Support

Did I answer your question? If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.

Anyone can be a marketer! Visit our Blog & Resources page to brush up on the latest tips and tricks.