Slow, Sluggish Website Response

Participant

Slow, Sluggish Website Response

I am finding Constant Contact to be sluggish and slow to respond, even on my fibre network. This seems to have coincided either with my switch to the new design version, or to a server change by Constant Contact. I sometimes wait 10-15 seconds for a CC server response and often when hitting Save I get a "There was an error performing your "Save" request, some of your changes may have been lost."

1 REPLY 1
Administrator

Hello @StanB005. Thanks for coming into the Community. I'm sorry that you were seeing this error when working in your account. I believe that you are experiencing a connectivity issue which might be caused by your browser. Have you tried using a different browser at all to access your account? Here is a list of the different browsers that work with Constant Contact.

 

If you find that Constant Contact works in a different browser, it's possible that the browser you are currently using has an extension or plugin that is affecting you being able to work in your account. You can try using either an incognito or private window or work to see which extension or plugin is causing this to happen using the steps in this article


Caitlin M.
Community Manager
Did I answer your question? If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.

You're not alone on your email marketing journey. Connect with a Marketing Advisor to see how they can help you develop the right strategy for your business and get the most out of your Constant Contact experience.