Video Link NOT working in sent email!

TraceyP845
Regular Participant

We have sent out a global email to all our clients with a video therein.  The video worked fine when it was tested prior to sending out, and now when you click on the link within the email the video does not work.  The video has not been moved.

 

We tested the link prior to sending out and it worked fine...

 

TraceyP845_0-1644232159754.png

 

When you click the video in the email that has been sent out, you get this....

 

TraceyP845_1-1644232217987.png

 

Can you explain why this would be?

 

 

6 REPLIES 6
William_A
Moderator

Hello @TraceyP845 ,

 

I tried checking the link in your Preview, and even that isn't working. Were any updates made to the video between testing and actually sending? Another think I noticed is that the link in preview opened with a %20 included, meaning an erroneous space was included in the pasted link. 

 

Regardless however, the link to the video doesn't appear to be valid, as it doesn't pull up for me either even when removing that space HTML coding. I believe the link that was used wasn't the Vimeo video's true share URL, but rather the address bar URL that Vimeo would've provided for the account's owner for editing. Or the Vimeo video used is still private / only viewable by the account owner, not others who access its URL.

 

At this point I'd advise doing a full resend of your email by copying it, adding a bit to the subject line about it being a correction or something like [Fixed Link]. Then check your Vimeo video to make sure you either have the true share URL for it, or check to make sure the video is public, and not hidden / private.

 

See also:

Using video blocks

Connecting the Vimeo integration

Managing Vimeo videos through the integrated Library


~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
William A
Community & Social Media Support
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Did I answer your question? If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.

Anyone can be a marketer! Visit our Blog & Resources page to brush up on the latest tips and tricks.
TraceyP845
Regular Participant

Thank you William

 

The pasted link into the email WAS a true link from the "share" option from Vimeo.  Everything was tested prior to sending out and the video worked when testing the link prior to accepting it into the email and also once a test email was sent out to myself and two other colleagues, the video link in the email worked as well - hence why we sent it out globally.  Obviously, if the video link had not been working then we would not have sent out the global email.

 

No changes to the video's location have been made either.  Neither is the video "private/only viewable by the owner".

In that regard, I'd advise reaching out to Vimeo's support, as the link that's in the video block doesn't navigate to a list. It does not appear to be an issue of the video block itself, as even pasting the link directly into my address bar still doesn't take me to the video.


~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
William A
Community & Social Media Support
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Did I answer your question? If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.

Anyone can be a marketer! Visit our Blog & Resources page to brush up on the latest tips and tricks.
TraceyP845
Regular Participant

Hi William

 

I have made a duplicate copy of the email that was sent out.  This is the video link contained within.

TraceyP845_0-1644851461864.png

 

I click "test link" and this takes me to the Vimeo page video as it should do.

 

TraceyP845_1-1644851518597.png

You can see that the URL is exactly the same.

 

I have sent myself a test email...

TraceyP845_2-1644851640624.png

 

The video link in the email works - I have sent this via email to you.

 

Therefore the issue appears to be after the email is sent globally to the contact database.

 

 

I went into your copied email, and edited the video to not have the erroneous space included. It would've appeared in the address bar when clicked as %20, would've just appeared in the video block's area to put the URL as a space. Once removed, the link worked in preview and test send. Please perform another preview / test send.


~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
William A
Community & Social Media Support
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Did I answer your question? If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.

Anyone can be a marketer! Visit our Blog & Resources page to brush up on the latest tips and tricks.
TraceyP845
Regular Participant

Thanks William

 

I have done a new test link and test email and both worked fine - but they worked fine prior to you removing the erroneous space in the URL anyway so I do not understand why then after sending out globally it would not work if it tested okay?

 

Regardless, I will now watch out for any additional spaces in any links going forward, but may I suggest that if there are any erroneous spaces in links pasted in, that your site throws up an incompatible message of some sort to avoid this happening - after all if something tests okay and is tested on email okay, then why wouldn't we send it out globally - if an error message popped up at the time of creation then this issue of links not working after sending out globally would not occur.

  • Support Tips

    Reporting Metrics

    "Authenticating your emails is the best way to ensure your emails achieve maximum deliverability. If you have your own domain, setting up self-authentication is especially important! " - Will

    See Article
    Avatar
  • Support Tips

    Call-To-Action Links

    "Target your most engaged contacts by creating a segment. Create a special offer or show your appreciation!" - Caitlin

    See Article
    Avatar
  • Support Tips

    Read Before You Send a Test Email

    "Did you know? You can send unlimited test emails to your verified email address, but only 50 in a 24-hour period to non-verified email addresses." - Nick

    See Article
    Avatar