Video Thumbnails

Highlighted
Frequent Visitor

Re: Video Thumbnails

I can not believe this is still an issue after all this time! Thumbnail from Youtube does not load. 

Highlighted
Moderator

Re: Video Thumbnails

Hi @BrianaS49 

 

I'm so sorry to hear you are still seeing this happen with your email campaign. With that said, are you still having this experience after trying the workaround from this thread? If you have not yet tested this workaround of deleting the video block and dragging in a new one, I would suggest doing so. I hope this helps!


Frankie.P
Community & Social Media Support

Did I answer your question? If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.

You're not alone on your email marketing journey. Connect with a Marketing Advisor to see how they can help you develop the right strategy for your business and get the most out of your Constant Contact experience.
Highlighted
Frequent Visitor

Re: Video Thumbnails

Workarounds don't solve this issue - I'm trying to load a video from Vimeo and I can't get the thumbnails to appear (the thumbnails really sell the videos ... they are funny to inspire clicks!). How do we solve this? 

Highlighted
CTCT Employee

Re: Video Thumbnails

Hi @SynchroNet.Net 

 

Thanks for joining us in the Community! We certainly understand why its frustrating when your video thumbnails don't appear for your readers. Are you currently seeing any specific error message when trying to insert the video? What is the link to the Vimeo video and is this video is currently private? We will attempt to replicate on your behalf.


Brian_H
Community & Social Media Support

Did I answer your question? If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.

You're not alone on your email marketing journey. Connect with a Marketing Advisor to see how they can help you develop the right strategy for your business and get the most out of your Constant Contact experience.
Highlighted
Occasional Visitor

Re: Video Thumbnails

I am having the same issues.  I insert the link and it displays a rainbow thumbnail with a play button.  I've tried all the work arounds in this thread.  Please let me know how to fix this.

Moderator

Re: Video Thumbnails

Hi @LaurenL2489 

 

Thank you for testing the workarounds in this thread! I apologize this different thumbnail is being pulled on this video block. Is this image an old thumbnail for the video? I have taken a look at your account and can see you were able to insert your video in your most recent campaign. Are you still in need of assistance with your video block? If so, it’s important to point out you are using a video hosted on Vimeo rather than YouTube like this thread is focused on. This lets me know you are having a different experience than that of these of these other users. We have recently received reports of color bars appearing when users insert a Vimeo URL into a video block. In these cases there are different workarounds you can try including:

 

  1. Copying the link from your video’s share option through the paper plane icon and inserting this URL into a new video block
  2. Creating an image screenshot of your video and inserting it as a clickable image
  3. Removing of the "s" from "https" in your video’s URL

 


Frankie.P
Community & Social Media Support

Did I answer your question? If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.

You're not alone on your email marketing journey. Connect with a Marketing Advisor to see how they can help you develop the right strategy for your business and get the most out of your Constant Contact experience.