CCSFG login problems

Highlighted
New Member

CCSFG login problems

I appear to be stuck in a loop trying to setup CCSFG. I've put in every combination of my API key and username i.e.: 1234-xxxxxxxxxxxxxxxxxxxxx%myUserName and I keep getting these types of errors:


We could not authenticate those credentials! Please try again.


or


It appears that this signup form has already been configured. As a result you will need to verify the access credentials to continue.


I've also tried just using my normal login name and password and nothing seems to work.


Any ideas?

5 REPLIES 5
Highlighted
CTCT Employee

CCSFG Login Failure

The CCSFG does not require the use of an API key, as it uses one shared API key for everyone using the CCSFG utility. After uploading the CCSFG, the username and password you are being prompted for at ../CCSFG_0.0.3/setup/ is your Constant Contact username and password. This is the same login information you would be using at www.constantcontact.com to login to your account. Please note, that this login information is not your developer forum username and password.


 


I would recommend logging into www.constantcontact.com to verify that you username and password are working there. If you are able to login into our website, and those same login credentials are failing for the CCSFG, please let us know. Thanks.

David J

Highlighted
Occasional Participant

Re: CCSFG Login Failure

Hi, I have the same problem and I have not touched any of the files.


I get the message 'Cannot open' when putting in my credentials. I have tried to log onto www.constantcontact.com and it worked fine.


Let me know please.


Regards,


Karl


 

Highlighted
CTCT Employee

CCFSG Authentication

The CCSFG generator does not require a unique API Key, as the all users of the utility share the same API key. The only thing required to use the CCSFG would be a valid constant contact username/password, and a web server to host the PHP files.


 


Once you enter your username and password for the first time, the utility attempts to authenticate those credentials with Constant Contact. Currently, if there are any issues with retrieving information from Constant Contact via the API, the error message “We could not authenticate those credentials! Please try again.” is displayed. If there are other issues which are causing the API call to fail, such as a cURL issue or another system configuration issue on the end of the server running the utility, the same error message would be displayed.


 


We are currently working on developing more robust error messaging in the utility in order to assist with troubleshooting these types of issue.

David J

Highlighted
New Member

Same problem

I am having this same problem. My username has a space in it and I'm wondering if that is the issue. I get "We could not authenticate those credentials! Please try again." 

Highlighted
CTCT Employee

space in user name

Hello,



Yes, the space in your username is not allowed when using our API's. You can change your username in the My Account link when you are logged into your account, and this should remedy your problem.



If you still have any questions please feel free to post them.



Regards,

Benjamin Soder
NOC Analyst
Constant Contact
Developer Portal

View API documentation, code samples, get your API key.

Visit Page

Constant Contact Would Like To Hear From You!

We want to hear from customers like you about your favorite features and how they have helped your business or organization. Tell us by answering a few questions in...

Read More
Featured