PHP 4?

Participant

PHP 4?

I recently inherited a web page that uses the ConstantContact api incorrectly. In order to fix it, I am trying to understand the api. I have the following code.

 

include_once('cc_class.php');
 $ccContactOBJ = new CC_Contact();
 $ccListOBJ = new CC_List(); 
  
 $list = $ccContactOBJ->getSubscriberDetails();
 print_r($list);

 

Simple enough, and it works just fine on my personal web server, which uses PHP 5. But when I put it on the company webserver, it prints the array information, but all fields are empty. So to me this means it is getting the array structure, but not the information in the arry. The only thing I can think of that is different between my personal web server and the company web server is that the company webserver runs PHP 4. Are there any known issues with using cc_class.php with PHP 4? Anything else you can think of that might be causing this problem?

1 REPLY 1
Employee

Hey,

 

We do have an older wrapper for PHP 4 which is not full featured like our new wrapper you can find in our code samples.  Which does require PHP 5 and cURL.  If you need the php 4 wrapper please email webservices@constantcontact.com.

 

 

Ryan Davis
Quality Engineer
Developer Portal

View API documentation, code samples, get your API key.

Visit Page