The Community is hosting an End of Summer sweepstakes! Participants must complete tasks to earn tickets that will enter them with a chance to win a free year of Constant Contact and other great prizes!*
*No Purchase Necessary. For Official Rules, visit here. Constant Contact’s End of Summer 2020 Sweepstakes ends on October 16th, 2020 at 11:59 PM EST.

Stop Automatic Save of Draft Emails After Every Edit

0 Votes

Automatically Saving Draft Emails in the Third Generation Editor after every edit s-l-o-w-s editing, makes the system 'glitchy', and must be making Constant Contact servers work overtime. Go back to the manual save option that was available in the Second Generation Editor. Edits to individual parts of an email in the Third Generation Editor should work the same as they did in the Second Generation -- once you click 'done' your edit is saved.

3 Comments
Employee
Status changed to: Open Questions

Hey @LisaB834, thanks for sharing this feedback. We enabled the autosave feature as customers were loosing content in situations where they lost internet connection, accidentally closed their browser windows, etc. It should be a passive feature and shouldn't be hindering your work flow. When you say that the editor becomes slow and "glitchy" after editing a block, what's happening on screen? Is the editor becoming unresponsive? 

 

 

Moderator
Status changed to: Closed - No Action

Thank you for taking the time to post in the Community. Since we haven't heard back from you we are going to close this idea. Though this doesn't mean that we aren't listening to your feedback! If you would like to continue the conversation, please feel free to reply here in the Community. You also have the option of voting on any of the other open ideas to let us know what you would like to see.

Member

I have to agree with this. Especially over wifi - every time I type something the system starts saving again and I cannot do anything until it is done saving. Something that should take less than 5 minutes to update is taking 10-15 because I constantly have to wait for the autosave to run. This is extraordinarily frustrating. If you have to have autosave, run it every 10 mins or so, not after everysingle keystroke or module change. Please.