We all started somewhere! Share your experience on the Get Advice: Let's Get Started Sweepstakes thread and be entered to win a $100 credit on your Constant Contact account.

Upload Not Working in Safari

Trying to upload images to my library, and not a single image will upload successfully. Each one says "error, please try again later". Is anyone else having this problem over and over again????

96 Comments
BrianJ6
Participant
I can't load regular, not large JPGs onto Constant Contact. These are the same types of files I have been using for year. Please look into this glitch.
RickI3
Participant
I get an error message and all the "details" say is that it cannot process the upload. It is 111kb jpeg image, 600px wide x 200px high. Help!!!
Hannah_M
Moderator
Status changed to: New
 
Hannah_M
Moderator
Status changed to: New
 
Kayte
Participant
I've tried decreasing image size, file size, file format... everything I can think of and the image won't load and the error message simply says we're having trouble processing your request, please try again. Well, I don't know how many more times I can try again.
TraceyT8
Participant
You've changed the system and I can't upload anything - whats going on?
Hannah_M
Moderator

HI Alyson,

I'm so sorry to hear this is happening. What type of file is the image and what browser are you working in?


Thanks!

SuzanneG58
Regular Participant

I'm having the exact same problem -- going on 2 days now and I really need to get an email out! I've tried all of those things, and nothing is working. I'm trying to upload a JPEG file. Any tips?? Thank you!!

SuzanneG58
Regular Participant

And my browser is Safari

Hannah_M
Moderator

Hi Suzanne,

Thanks for the detail. Do you have another browser on your computer you can try uploading from? We're aware of and working to resolve some problems with uploading in Safari but you should not have any problem in another browser. Firefox and Chrome are great and are available as free downloads online.

 

Thanks for your patience. We will update as soon as we have mooe information. 

BradB50
Participant
I am trying to upload a image and it is not working.
CharleneS9
Participant
I am getting a vague error message when I try to upload images with the new interface. I even tried uploading images that I know uploaded without trouble last week.
CharleneS9
Participant

I am having trouble with the new interface as well.  Even uploads that worked last week are not working now??

Hannah_M
Moderator

HI Brad,

Are you working in Safari or another browser?

SuzanneG58
Regular Participant

I'm working in Firefox now, and having much better luck with uploads! Thanks so much for your help, Hannah!

What happens with product feedback?

Find out about the life-cycle of a product idea when it is posted on our Feedback board.

Read More

What's New

See the latest Constant Contact product release notes and updates.

Learn More