cancel
Showing results for 
Search instead for 
Did you mean: 

"Subscribe me" links broken

SOLVED

"Subscribe me" links broken

forwarded emails contain a "Subscribe me" link at the top, but the clicked link redirects to a broken page. I have checked multiple accounts so the problem seems to be on the constant contact side.
5 REPLIES 5
Moderator

Re: "Subscribe me" links broken

Hello @Berkshire_Grown,

 

That is very strange indeed! I did a cursory review of your last couple of campaigns and it appears you are using both of our editors. Are you seeing this issue appear in both of them? The newer, third-generation editor does not have a forward function built-in to the footer like the older editor does. Therefore, it would have to be forwarded from the email client itself. Does the "Subscribe Me" link appear at the top in the body of the email or does it look like it is part of the email client you are viewing it in? If you are referring to a campaign created in the older, second-generation editor are you using the "Forward this email" function in the footer?

 

We definitely want to look into this. I encourage you to send us an email at social_support(at)constantcontact(dot)com with the following information:

 

1. Your username.

2. The name of the campaign that you forwarded.

3. Did you forward from the email client or the footer of the email?

4. What email client are you seeing this "Subscribe Me" link in?

5. Make a reference to this post.

 

With this information we will investigate further and try to get to the bottom of this!


Nick S.
Social Media & Content Manager

Did I answer your question? If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.

Anyone can be a marketer! Visit our Blog & Resources page to brush up on the latest tips and tricks.
Member

Re: "Subscribe me" links broken

I see exactly the same issue. When I click "Subscribe me" on a forwarded email, it brings me there:

https://visitor.constantcontact.com/error_general.jsp

Could somebody help to resolve it? Thank you.

Moderator

Re: "Subscribe me" links broken

Hello @GatesPTO. I apologize for the delay in our response! We've had some reports of this link not working in forwarded emails and I'm sorry that you are seeing this as well. I can understand how you would want new contacts to easily sign up for your newsletters. What we recommend is to include a link to your sign-up form in the body of your email so these new contacts have the ability to join your mailing list. 


Caitlin M.
Community & Social Media Support

Did I answer your question? If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.

Anyone can be a marketer! Visit our Blog & Resources page to brush up on the latest tips and tricks.
Member

Re: "Subscribe me" links broken

We too would like to see the "Forward to a Friend" feature restored and the link fixed. I had to laugh that this issue is marked as "Resolved." NOPE. 

CTCT Employee

Re: "Subscribe me" links broken

Hello @ChristC.

 

Thank you for your feedback about the Forward to a Friend option. We are still collecting feedback on this and we will be sure to submit your request to the appropriate teams! Please let us know if you have any questions.

 

 

-Curtis P
Community & Social Media Support

If you find my post helpful, and it answers your question, please mark it as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.

Increase your profitability by integrating your email marketing and social media. Download this guide and learn how you can achieve great results with email marketing and social media combined!