Significant Delays Adding a Professional Email

KevinM676
Participant
0 Votes

I own a number of domains for two business in the CC platform, I manage them within the Google Workspace platform, this week I tried to add an email for an employee under one of the domains, and I received a processing order notice. After waiting 1 day to process order, which did land on my CC as paid, I contacted website builder support, via chat (only mechanism to contact them), they processed a support ticket, were to notify me on status never did. I got an email from the website builder fraud department, saying I could add the email. Unfortunately that was not the case. We went back in to contact website builder support via chat (as you cannot speak to them) and consistently got a message chat was not available. We then called CC support TP # elevated our concerns to the senior Support 1 level, and were told they would contact website builder and call us back. No phone call, not response. We called back to senior Support 1 and were then told they have not control or ability to contact website support builder, although they did give us an elevated support email for them, we contacted them, explain our issues, got another support tix, and 6 days later have 0 response from anyone. We again went into website builder chat yesterday, started over, they had 0 record of any of our previous support tix, and started a new one. Unfortunately the employee we hired resigned as we are now 7 days in and cannot add a simple email to a domain we own in the platform. This is coming from a 10 year client of Constant Contact. 

2 REPLIES 2
Caitlin_M
Administrator
0 Votes

Hi @KevinM676. I'm sorry that you were not able to successfully connect with the Website Builder team. We submitted a ticket to ask that team to contact you regarding your domain.

--

Caitlin M.
Community Manager
KevinM676
Participant
0 Votes

Caitlin - thanks greatly we have invested over 4.5 hours with the website builder team and have been notified of many tickets for this issue, we have not received an update on any of them since the original request was logged on Monday 1/9 AM EST. At this point we are stuck with no where to go.