Server Flow - Token Refresh not working

MikeK7170
Regular Participant

Server Flow - Token Refresh not working

Every time I try to use a "refresh_token" request I get a 400 error. I am using the latest refresh_token and the URL in the API documentation. I pass the credentials (API Key and API Secret) and do a POST. I am using Java, but no matter what I do I get a 400 error.

There seems to be an issue with the interface, or the code in the sample is wrong and I am missing something. 

 Any help is appreciated.

 

2 REPLIES 2
MikeK7170
Regular Participant

After doing more research I found this discussion (https://community.constantcontact.com/t5/Developer-Support-ask-questions/Refresh-token-not-working/m...)

 

It answered my problem. It was a matter of a refresh_token being generated but, not updating in my central database, and then the 2nd attempt failed.

Hello MikeK7170,
 
Thank you for reaching out to Constant Contact API Developer Support. My team is here to assist outside software developers with questions about building into Constant Contact's API.

 

I'm glad to see that you were able to get the issue resolved. Please let us know if you have any other questions or feedback. We're happy to help.

 

Regards,


John B.
API Support Specialist
Did I answer your question? If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.
Developer Portal

View API documentation, code samples, get your API key.

Visit Page