Error when editing images

0 Votes

Hi there.  This is the second week I have tried to download a photo and edit it with your new system. I thought last week it was because the system was new and you were still working on it, but this week it still doesn't work.


I get the photo fine, and push "edit" and can crop the photo like I want it, but there is a message that something went wrong each time.  I would appreciate it more if it worked.


Thanks for the updates, most of it really looks great.


Melody Miller

Status changed to: New

Thank you for the feedback @MelodyM6,


We are currently working to the fix this issue you're running into.  In the meantime if you go to your 'Library' tab you should be able to edit your images without seeing this error. 

I'm moving your feedback over to another thread with this feedback and we will update everyone when this is fixed.


Thanks again!

Status changed to: Voting Open

I have been having the same problem for weeks now and it's making me crazy, because I heavily edit my photos and create graphics. I tried using the library to edit and it doesn't really work - first of all the dialogue window is much smaller, and if I am actively building an email the new edited image doesn't refresh along with the image I'm inserting. It keeps reverting back.

Status changed to: Closed - Implemented

Thanks for the reports. This appears to have been a bug that was fixed shortly after Patrick's original response.

Introducing our new Feedback area

Our Feedback board is changing! From updated statuses to clearer processes, we're working to improve the conversation between you and our Product teams

Visit the Blog
What's New?

See the latest Constant Contact product release notes and updates.

Learn More