New Authorization Service and Using Wildcards

SOLVED
Go to solution
AvromFinkelsteinF
Frequent Participant

Hi,

 

I'm trying to port over our application to use the new authorization service and I made a copy of our app as per the instructions here:

https://v3.developer.constantcontact.com/api_guide/auth_update_apps.html

 

Our redirect URL goes to localhost, however, the port number may be different depending on the circumstance so I have:

http://localhost:*/ccauth as the redirect.

The * wildcard allows me to specify a different port number.

 

Now, for the new copied app it has this error:

This redirect URI uses an unsupported wildcard character. The redirect URI must be an absolute URI.

 

Does this mean that there is a supported wildcard character or does this mean that wildcards are no longer accepted at all?

If there is a supported wildcard char, what can I use to indicate different port #?

1 ACCEPTED SOLUTION
John__B
Employee

Hello AvromFinkelsteinF,

 

Thank you for reaching out to Constant Contact API Developer Support. My team is here to assist outside software developers with questions about building into Constant Contact's API.

 

Wildcards are currently not supported for the redirect URI except at the lowest level subdomain. That being said, you can set up multiple redirect URI’s to use for your application. For more information on this I am including documentation below.

 

OAuth 2.0 Authentication Overview:

https://v3.developer.constantcontact.com/api_guide/auth_overview.html

 

One potential workaround you could use would be to listen for all responses on one port, have the ‘final’ port number encoded in the state parameter and then forward the response to the correct port.

 

If you could provide some more information about your use case for using a dynamic port number, we could look into potentially offering a different solution.

 

Please have a look and let us know if you have any other questions!

 

Regards,


John B.
API Support Specialist
Did I answer your question? If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.

View solution in original post

3 REPLIES 3
John__B
Employee

Hello AvromFinkelsteinF,

 

Thank you for reaching out to Constant Contact API Developer Support. My team is here to assist outside software developers with questions about building into Constant Contact's API.

 

Wildcards are currently not supported for the redirect URI except at the lowest level subdomain. That being said, you can set up multiple redirect URI’s to use for your application. For more information on this I am including documentation below.

 

OAuth 2.0 Authentication Overview:

https://v3.developer.constantcontact.com/api_guide/auth_overview.html

 

One potential workaround you could use would be to listen for all responses on one port, have the ‘final’ port number encoded in the state parameter and then forward the response to the correct port.

 

If you could provide some more information about your use case for using a dynamic port number, we could look into potentially offering a different solution.

 

Please have a look and let us know if you have any other questions!

 

Regards,


John B.
API Support Specialist
Did I answer your question? If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.

Thanks.

 

I came up with an alternative solution for my use case where it didn't rely on dynamic port numbers.

 

After I had written my post, I did see your documentation where it mentioned:

"Wildcards are not supported except at the domain root level."

See https://v3.developer.constantcontact.com/api_guide/server_flow.html

 

I think the error message in the app is a bit misleading as it implies there is an issue with the wildcard char of * itself.

John__B
Employee

Hello AvromFinkelsteinF,

 

Thank you for reaching out to Constant Contact API Developer Support.

 

We appreciate your feedback regarding this error message. I’m going to bring this to our development team and see if we can update the verbiage to reflect that wildcard characters are supported at the lowest level subdomain.

 

Please let us know if you have any other questions!

 

Regards,


John B.
API Support Specialist
Did I answer your question? If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.
Resources
Developer Portal

View API documentation, code samples, get your API key.

Visit Page

Announcements

API Updates

Join our list to be notified of new features and updates to our V3 API.

Sign Up