Error while updating to v3

SpencerF23
Regular Participant

While trying to update to version 3 of the api, I am getting an error.

 

When I send this URL to generate access token

https://authz.constantcontact.com/oauth2/default/v1/authorize?client_id=edf8807c-1f10-430a-954a-45e8...

I receive this:

http://localhost:3000/?error=invalid_request&error_description=The+authentication+request+has+an+inv...

 

Thanks!

1 REPLY 1
John__B
Employee

Hello SpencerF23,

 

Thank you for reaching out to Constant Contact API Developer Support. My team is here to assist outside software developers with questions about building into Constant Contact's API.

 

The reason you encountered this error is that your authorization request URL did not include the state parameter, which is required for the initial authorization request. The state parameter is an arbitrary string value used to uniquely identify a user’s session. For more information on this parameter, you can review the Request Parameters section under Step 1 of the Authorization Code Flow documentation I’m linking below.

 

V3 API Authorization Code Flow:

https://developer.constantcontact.com/api_guide/server_flow.html

 

Please have a look and let us know if you have any other questions!

 

Regards,


John B.
API Support Specialist
Did I answer your question? If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.
Resources
Developer Portal

View API documentation, code samples, get your API key.

Visit Page

Announcements

API Updates

Join our list to be notified of new features and updates to our V3 API.

Sign Up