Power Automate losing authentication after set time

SOLVED
Go to solution
user7446451
Occasional Participant

Hi there, I've created a custom connector for Power Automate. It works fantastically until the authorization expires then consistently 401 fails until I refresh the token manually. 

 

In terms of the custom connector I assume it uses the Server Flow with the refresh URL and have input all the URLs based on this. 

 

Any clues on keeping authentication would be greatly appreciated. 

 

Hugh

1 ACCEPTED SOLUTION
Courtney_E
Moderator

Hello user7446451,

 

Thank you for reaching out to Constant Contact API Developer Support. My team is here to assist outside software developers with questions about building into Constant Contact's API.

 

As Power Automate / Microsoft Flow is a 3rd party product and not built or supported by Constant Contact, we are limited in the support we can provide, but will try to answer any questions to the best of our ability as they pertain to Constant Contact’s API endpoints and functionality.

 

From what we understand, the issue users run into regarding Power Automate / Microsoft Flow not refreshing the token set for the V3 Oauth2 Server Flow is suspected to stem from their system expecting an access token in JWT format. An error seems to occur while attempting to parse the token, which leads to the refresh failure.

 

I was able to find this related community post in Microsoft’s public Power Users forum that may offer some additional insight on possible resolutions (link below), but if you need further assistance with setting up an Oauth2 authentication within Power Automate / Microsoft Flow in a way that supports refreshing the token set, you’d want to reach out to their support team directly for assistance: 

 

[3rd party link] https://powerusers.microsoft.com/t5/Connecting-To-Data/How-to-connect-custom-API-using-own-OAuth2-in...

 

However, you may want to postpone troubleshooting that is specific to the current OAuth flow, as there are upcoming enhancements that will be released/announced in the next couple of weeks. These will require some changes to be made to existing V3 apps, which may make the current issue irrelevant. Once these changes are announced/released, please take a look in the updated documentation and feel free to let us know if you have any follow-up questions:

 

Constant Contact V3 API Release Notes

https://v3.developer.constantcontact.com/api_guide/release_notes.html

 

Please have a look and let us know if you have any other questions!


Regards,

Courtney E.
Tier II API Support Engineer

Did I answer your question?
If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.

View solution in original post

1 REPLY 1
Courtney_E
Moderator

Hello user7446451,

 

Thank you for reaching out to Constant Contact API Developer Support. My team is here to assist outside software developers with questions about building into Constant Contact's API.

 

As Power Automate / Microsoft Flow is a 3rd party product and not built or supported by Constant Contact, we are limited in the support we can provide, but will try to answer any questions to the best of our ability as they pertain to Constant Contact’s API endpoints and functionality.

 

From what we understand, the issue users run into regarding Power Automate / Microsoft Flow not refreshing the token set for the V3 Oauth2 Server Flow is suspected to stem from their system expecting an access token in JWT format. An error seems to occur while attempting to parse the token, which leads to the refresh failure.

 

I was able to find this related community post in Microsoft’s public Power Users forum that may offer some additional insight on possible resolutions (link below), but if you need further assistance with setting up an Oauth2 authentication within Power Automate / Microsoft Flow in a way that supports refreshing the token set, you’d want to reach out to their support team directly for assistance: 

 

[3rd party link] https://powerusers.microsoft.com/t5/Connecting-To-Data/How-to-connect-custom-API-using-own-OAuth2-in...

 

However, you may want to postpone troubleshooting that is specific to the current OAuth flow, as there are upcoming enhancements that will be released/announced in the next couple of weeks. These will require some changes to be made to existing V3 apps, which may make the current issue irrelevant. Once these changes are announced/released, please take a look in the updated documentation and feel free to let us know if you have any follow-up questions:

 

Constant Contact V3 API Release Notes

https://v3.developer.constantcontact.com/api_guide/release_notes.html

 

Please have a look and let us know if you have any other questions!


Regards,

Courtney E.
Tier II API Support Engineer

Did I answer your question?
If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.
Resources
Developer Portal

View API documentation, code samples, get your API key.

Visit Page

Announcements

API Updates

Join our list to be notified of new features and updates to our V3 API.

Sign Up