Browser incompatibility issue

0 Votes
Yesterday as I worked on an email in Chrome I encountered a fairly new but now chronic issue. Namely, a photo that was not apparent (therefore not removable) appeared in my tested email when received by both me and my client. So I opened CC in Firefox. Same problem. That image was like a phantom picture - not in the editor, but showed up in my Inbox. When I finally resorted to using Safari (on my Mac Desktop- Mojave 10.14.6) I could see the image in the editor and therefore replace or remove it. I have discussed this with CC on the phone in the past, but as is so often the case, there was little concern for the problem, and their only suggestion was to either switch browsers (really?) or imply the problem was mine because I had copied an older email. Reusing an email had never been a problem in past years; this is a new issue. I hope your team can take this seriously and figure out where the issue is and fix it. It would be greatly appreciated to have this software work properly.
1 Comment
Moderator
Status changed to: Open Questions

Hi @Assist-Deb thank you for sharing your feedback on this experience you've had with your email campaign. With that said, emails with a hidden block that does not show while in the editor but will appear in the preview test or live send versions is a defect we are continuing to troubleshoot. I apologize this is not something all users experience which can cause us to not have a time estimate of when it be resolved. I will however track your feedback on this to the appropriate teams and open your idea so other users can weigh in as well. In the meantime, does our workaround of trying a different browser not resolve this experience to edit and remove this block?

What happens with product feedback?

Find out about the life-cycle of a product idea when it is posted on our Feedback board.

Read More