Error in V3 API

WCCGoldenApple
Brand Visionary
0 Votes

There is a bug in the new V3 OAuth2 API.  The server is not accepting URL encoded strings.  In particular, the scopes must be separated by a plus sign (+).  As an properly encode URL, they should be %2B, but that does not work.  You have to pass them as an actual plus (+) sign.

 

This used to work correctly in the previous version of the OAuth2 API, but appears to have been broken with the new PKCE end points.  I have a workaround (use + instead of %2B), but I think this should be fixed.

 

More details here: https://community.constantcontact.com/t5/Developer-Support-ask-questions/One-or-more-scopes-are-not-...

 

Thanks!

1 REPLY 1
Courtney_E
Moderator
0 Votes

Hello WCCGoldenApple,

 

Thank you for reaching out to Constant Contact API Developer Support. My team is here to assist outside software developers with questions about building into Constant Contact's API.

 

We greatly appreciate you bringing this to our attention. It looks like we have already reported this issue to our development team in response to your previous post: https://community.constantcontact.com/t5/Developer-Support-ask-questions/One-or-more-scopes-are-not-...

 

Please have a look and let us know if you have any other questions!


Regards,

Courtney E.
Tier II API Support Engineer

Did I answer your question?
If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.
Resources
Developer Portal

View API documentation, code samples, get your API key.

Visit Page

Announcements

API Updates

Join our list to be notified of new features and updates to our V3 API.

Sign Up

Polls
How confident are you about the effectiveness of your current marketing strategy?

Top Choice: Not confident at all (63%)