"Images are not displayed" issues on Gmail?

Retail

"Images are not displayed" issues on Gmail?

No matter how many times I click "Always display images from...", Gmail is not automatically displaying my images.

This wasn't a problem a month or so ago. I'm not aware that I've changed anything that would cause this to be a problem (it doesn't occur with any other CC emails I receive from other companies, nor any other marketing emails).

 

Anyone else seen this lately?

 

images.PNG

7 REPLIES 7
Moderator

Hi @SteveD11 

 

Thank you for reaching out about your email! This screenshot you have provided definitely helps to understand what exactly you're experiencing. With that said, images in an email sometimes don't display for a variety of reasons. You mentioned clicking "always display images." Have you also checked your Gmail account's settings to make sure images are selected to always display? If not, I would suggest doing so. You can also whitelist Constant Contact in your security settings. Are you still seeing images not download after taking these steps?

 

 


Frankie.P
Community & Social Media Support

Did I answer your question? If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.

You're not alone on your email marketing journey. Connect with a Marketing Advisor to see how they can help you develop the right strategy for your business and get the most out of your Constant Contact experience.

Yes, that option to always display is already checked. 

And to make things weirder, my coworkers aren't seeing the same issue, so it's not a domain-level issue. 

Hello @SteveD11 ,

 

If the Always Show option is always on, the only other elements would be:

If these steps are still causing your the emails to not display images by default, we can try to get a case submitted to our higher level technical team for further review or a remote session to see what might be causing this issue to only affect you. Please let us know the results of the troubleshooting steps above.


William D
Community & Social Media Support

Did I answer your question? If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.

Anyone can be a marketer! Visit our Blog & Resources page to brush up on the latest tips and tricks.

I'm having the same issue and have been for about a month. I also receive emails via CC from other Senders and am unable to view the photos. Attached are screenshots. Mine is the first one and the second screenshot is from a different Sender.Screen Shot 2020-05-23 at 10.02.51 AM.pngScreen Shot 2020-05-23 at 10.03.18 AM.png

Hello @ErikaS424,

 

Thank you for reaching out about your email! This screenshot you have provided definitely helps to understand what exactly you're experiencing. With that said, images in an email sometimes don't display for a variety of reasons. You mentioned clicking "always display images." Have you also checked your Gmail account's settings to make sure images are selected to always display? If not, I would suggest doing so. You can also whitelist Constant Contact in your security settings. Are you still seeing images not download after taking these steps?


Zoe H.
Community & Social Media Support

Did I answer your question? If so, please mark my post as an "Accepted Solution" by clicking the Accept as Solution button in the bottom right hand corner of this post.

You're not alone on your email marketing journey. Connect with a Marketing Advisor to see how they can help you develop the right strategy for your business and get the most out of your Constant Contact experience.
Occasional Participant

I'm having the exact same issue.  PLEASE STOP RESPONDING WITH CANNED RESPONSES.   This issue needs to be escalated.  There is clearly an issue with constant contact messages not displaying images in gmail's client.

Yeah, this isn't a whitelisting issue. Like I mentioned, other people on the same network & domain DON'T experience this, so it's a weird that it's just impacting my one account.