Segments not loading

DebraG442
Constant Contact Partner
0 Votes
For several months now, we have been trying to update our segmentations and they a) take forever to load - I am talking about hours upon hours and b) once they do "load" it shows X amount of contacts, but when you open the segment no contacts will show. I am unable to even use the segments at that point. We then have to create the same exact segment, over and over again, until it finally properly loads wasting hours just trying to get segmentation to work. Is anyone else running into this issue as well?
2 REPLIES 2
Caitlin_M
Administrator

Hi @DebraG442. Our product teams are aware of a longer processing time when creating or updating segments and they are actively investigating the issue. There isn't any information to share at this time in regards to a date when a fix could be implemented so until then, you will experience an increased wait time for the segment to be created and populate with contacts. 

--

Caitlin M.
Community Manager
612kruth
Rookie
0 Votes

We are unable to refresh segments. Click the refresh segments link, but nothing happens. On 4/19/24, we were told that we would be notified when the issue was resolved. It's still not working. Are others still experiencing this issue? 

 

Updates
Just Getting Started?

We’re here to help you grow. With how-to tutorials, courses, getting-started guides, videos and step-by-step instructions to start and succeed with Constant Contact.

Start Here

73% of SMBs express doubt that their marketing strategy is effective. Does this sound familiar? Read our Small Business Now Report to learn how you can tweak your strategy to see better results.

Go read our article
Upcoming Webinars
JUN 27
Boost Your Email Results with Segmentation & Personalization
2PM - 3PM EST
JUL 10
Getting Started with the Constant Contact Community
2PM - 3PM EST