Cannot insert video into campaign

SOLVED
Go to solution
Rev SaraM-1970221203
Rookie
0 Votes

I have uploaded a video to Youtube that I want to put into my campaign. The video is fully uploaded, processed and has a thumbnail. I keep getting an error message that Constant Contact cannot find the video thumbnail and thus cannot insert the video. I have tried, closing the campaign and opening it again. Deleting and putting in the video block doesn't work either. This is seriously so frustrating!!!

1 ACCEPTED SOLUTION

I had to do a work around. I downloaded the thumbnail from Youtube, inserted it into the campaign as a picture and then added a link to the picture. Please fix this issue so that I do not have to do this workaround anymore. There is no play button on the video thumbnail so it doesn't look a video. 

View solution in original post

2 REPLIES 2
Caitlin_M
Administrator
0 Votes

Hello @Rev SaraM-1970221203. I'm sorry to hear that you had difficulty inserting a video into your email. I took a look at your most recent email and saw a video clip was included. Was this the video that was not pulling in a thumbnail? If so, do you recall how the video was inserted in the end?

--

Caitlin M.
Community Manager

I had to do a work around. I downloaded the thumbnail from Youtube, inserted it into the campaign as a picture and then added a link to the picture. Please fix this issue so that I do not have to do this workaround anymore. There is no play button on the video thumbnail so it doesn't look a video. 

Updates
Just Getting Started?

We’re here to help you grow. With how-to tutorials, courses, getting-started guides, videos and step-by-step instructions to start and succeed with Constant Contact.

Start Here
Upcoming Webinars
May 1
Constant Contact Community Walkthrough and Demo
2PM - 3:00 PM EST